Wireless router bridging for the overconfident
November 13, 2010 3:49 AM   Subscribe

DD-WRT transparent wireless bridging. Nothing is working, not even changing the settings by hand over telnet. (On the plus side, I've learned how to use iptables.)

It's the usual story - I'd like to connect a DLNA-capable TV to the rest of my home network, and using a spare router running DD-WRT seemed like a clever way to do it.
Most of the solutions offered to past questions like this involve settings that no longer exist, or buying separate hardware. That's not an option - this isn't about streaming movies anymore, it's the cosmic struggle of Man Versus Machine.
Builds of DD-WRT that support my hardware (an Airlink AR670w) no longer offer Client Bridged mode, just AP, Client, Repeater, and Repeater Bridge. The Repeater modes have never worked (they won't connect to an outside router, site scanning shows nothing) AP works great but is wrong for this, and Client works, but it performs NAT between the wired clients and outside router.
Most of my efforts have been on adding bridging to Client mode. So far I've tried using DMZ to make the TV visible to the rest of the network (it is, but it won't talk to anything on a different subnet) bridging wifi and Ethernet using brctl (nothing gets forwarded for whatever reason - note that bridging between wired and wireless works fine in AP mode) deleting everything from iptables' nat and filter tables (works, but requires static routes to be manually set up, which I can't do on the TV) and two-way NAT to trick both sides of the network into only seeing the router (appears to work, but fails on the "Gateway" portion of the TV's Byzantine connectivity test)

I'm at my wits' end over a basic networking problem. There has to be something obvious I've overlooked that's making all these programs behave wrong. Please tell me what it is.
posted by marakesh to Computers & Internet (6 answers total)
Have you flashed the full version of DD-WRT? For the Airlink, you've got to flash the webflash image first, and then flash the full version. The router DB indicates that it supports v24 preSP2, so it should have full client bridging capabilities. Also, can I assume that you've seen this set of instructions? They do say "confirmed working with SP2," so it should be possible.
posted by god hates math at 6:50 AM on November 13, 2010

If your wired router is, then set the ip of your bridged router to

Disable DHCP on your bridged router. Make sure anything connected to it has as the gateway.

That should resolve your problem.
posted by empath at 10:07 AM on November 13, 2010

Response by poster: It's running the webflash version of the newest SVN build I could find when I last had to reflash it (build 15506), available here. I'll try updating, I didn't know there was really a difference between the webflash and regular versions.
I don't know if I've tried the instructions on that particular page, but I've basically given up on anything involving the web interface.

Right now I can't get it to forward DHCP requests reliably, but the DHCP server is set to only use the wired interface, so that's okay-ish. AFAIK, the default gateway is only used when going outside of the local network, and Internet access is working fine already. When I put my laptop in place of the TV, and try to ping something connected to the main router, it gives me a "destination unreachable" error from the laptop's NIC until I add a static route for If there were a way to add that to the TV's routing table, that would be great.

It would be nice to get this working, but what I'd really like to know is why. brctl, as documented, should do exactly what I need in this situation, but in fact it does nothing. And the web interface just runs configuration scripts for it and some other basic Linux networking tools. So why does the web interface work (for some things) and not anything I've tried?
posted by marakesh at 1:40 PM on November 13, 2010

Don't use DHCP. Just set your tv with a static ip with the following settings:

TV Settings
Ip address:
192.168.1.foo (whatever address is free)
Gateway: (your wired router address)
Subnet mask:
DNS Servers: (Google's) (Level 3's)

Bridged Router Settings
Ip address: (something unused)


Subnet mask:

The main two things is that everything is on the same subnet, and everything is using the same gateway. Your bridged router won't be NATing, because everything is going to be using your wired router as the gateway.
posted by empath at 6:14 AM on November 14, 2010

Response by poster: Empath, I really appreciate the effort you're putting into helping solve this. After reading through what I actually wrote, though, I can see I've been explaining myself very poorly: The TV can connect to the Internet fine, the problem is getting it to talk to computers elsewhere on my home network, that are connected via the main router.

Here's my network:

Main router (local IP server (
Bridged router (
Laptop ( [to be replaced with the TV once this works]

If I try to ping the media server from my laptop, I get the error "Attempting to ping Response from Destination host unreachable." Once I add a static route to the laptop, instructing it to reach through the gateway, it works fine. My understanding is that this is actually correct behavior: the laptop assumes that anything in its subnet can be connected to directly. Unfortunately, it will only talk to servers in its subnet, and I can't add static routes to it.
posted by marakesh at 4:27 PM on November 14, 2010

Response by poster: It's finally working using these instructions. Apparently the trick was to clone the host router's MAC, of all things. Still no idea how or why that works, but next time I'll leave this stuff to the pros.
posted by marakesh at 8:00 PM on November 14, 2010

« Older Clothing repair in the UK that replaces Jeans...   |   Papa Noel for American peeps. Newer »
This thread is closed to new comments.