Automatically set XP folder permissions.
March 30, 2005 8:49 AM   Subscribe

I have problems sharing new folders on my home LAN. I have an XP pro box, my wife has a WinME laptop.

I share my MP3 folder with her, mostly glitchfree. However, whenever I add new subfolders to the main MP3 one, she has problemas playing the files. She can see them both in explorer and winamp, but they refuse to play, sometimes locking up winamp or her entire system, forcing a hard reboot (I know, ME sucks). Usually, I go into the folders "security" settings, play around a bit, try to set everything to "full control", and after a few tries get it right.

Question: How can I make it so any new folders automatically have their permissions set so she can see/play the files in them?

Assume I know very little or nothing about how XP's security/user/etc model works, and managed to set up the network mostly by luck and blindly twiddling knobs.
posted by signal to Computers & Internet (4 answers total)
When you are looking at the folder properties, click on the security tab; You should see your wife's computername / username. The box reading "allow inheritable" should be checked. When you click on the advanced button, you should see the permission entries. In the column "apply to" it should read this folder, subfolder, and files. Under "permission" it should read full control. If not, remove her and add her back, pulling the account from "look in"; When the object window is open, choose "allow" for all and make sure apply onto has "this filder, subfolders, and files"

This should address any problems; Subsequent created directories (sub) will inherit these permissions.
posted by AllesKlar at 10:13 AM on March 30, 2005

Response by poster: Hmm. First, my wife's computername / username doesn't show up in the "group or user names" box. I've never set up an account for her on my computer or configured hers to use one (in fact, I don't know how to do this). I just point her to my computers IP (on the LAN) in her tcp-ip settings.
I do, however, have "Everyone" , as well as "users(Server users)". Also, I don't see the "allow inheritable" box at all.
posted by signal at 10:21 AM on March 30, 2005

Ok, I am working with Win2k so I was assuming things were that similar. This link should answer permission questions.
posted by AllesKlar at 10:27 AM on March 30, 2005

As a side note; if you are sharing an internet connection or have some kind of wireless network, etc. for security reasons / peace of mind, it would be better to setup an account for her computer instead of the blanket account "everyone."
posted by AllesKlar at 10:30 AM on March 30, 2005

« Older Are free business magazines worth it?   |   Where did I read this? Newer »
This thread is closed to new comments.