Troublesome wireless connectivity...
September 5, 2010 1:55 PM   Subscribe

I'm having a wireless connectivity issue that is proving troublesome. My Windows XP-equipped desktop won't connect wirelessly to the internet about 90% of the time. Intermittently, it will connect and browsing proceeds normally. If I connect via LAN Ethernet, all is well. I'm using a Netgear WG111 v2 wireless adapter connected via USB to my desktop. My wireless router is a Netgear WGR614 v6

I have two laptops working online through the same wireless router just fine, no issues connecting at all. I also have an Xbox successfully connected directly to my cable modem, so it seems my incoming internet connection is fine.

If I use Windows to configure my desktop wireless connection, it very rarely succeeds connecting to my network (it shows 4 out of 5 bars for signal strength) . I can sometimes connect to a rouge open weak signal (1 or 2 bars) coming from a neighbor, I presume.

If I use Netgear's "Smart Wizard Wirerless Assistant" to manage the connection, it connects to my router (58% signal strength), but then punks out at "acquiring network address" and then finally says "limited or no connectivity."

So, any ideas on what it will take to resolve this? I'm pretty stymied...

(BTW, this issue started about 2 months ago. Before that, the connection was pretty rock-solid for 3+ years with the same set-up.)
posted by Exchequer to Computers & Internet (11 answers total) 1 user marked this as a favorite
 
Did you try switching the channel you're using? There are certain default channels that almost everyone uses, and with more and more people having wireless networks close together, sometimes people get stepped on.

When I started having connectivity issues like this, I changed from "13" or whatever the default is to a random channel, and everything worked great!

(I learned this from an old AskMe answer).

posted by drjimmy11 at 2:19 PM on September 5, 2010


I just changed the router's broadcast channel from 11 to 6, no change, laptops still working fine.

I'm using WEP, BTW...
posted by Exchequer at 3:15 PM on September 5, 2010


I loathe that USB dongle. It was the bane of my life. Test to see whether you can connect if you turn off the encryption. If so, then it's a problem with using WEP, which I could never get to work with the USB adapter.
posted by stoneweaver at 3:27 PM on September 5, 2010


Try updating drivers?

I had this problem on my old Windows desktop that has a NetGear USB annoyance device. I had a workaround. Let me boot it up and check it out. [...]

Try this:
1. Right click the "Terminal and red X" status try icon and click "View Available Wireless Networks."
2. It says some shit about "Windows cannot configure the wireless connection." Say "Fuck you in the FACE, Windows and/or NetGear," and click on "Change Advanced Settings."
3. Now you're in NETGEAR Wireless properties, which you could have got to from some other way if you prefer to be all FUCK YEAH I'M GONNA USE THE MANAGER INTERFACE.
4. Click the "Wireless Networks Tab".
5. Is the "Use Windows to configure my wireless network settings" checkbox checked? If not, click that bitch, then click OK, and watch as your piece of shit computer connects to the fucking internet.

That work for you? I may have written too many test cases in my life. Does it show?

And no I haven't ever been arsed to fix the underlying problem. Laptops, motherfucker.
posted by fleacircus at 3:45 PM on September 5, 2010


If the fix from fleacircus works be aware that in my experience I had to do it every time I turned on the computer. To cope, I used hibernate pretty much exclusively.
posted by stoneweaver at 3:53 PM on September 5, 2010


My husband was having this problem after moving his home office from our to-be-born baby's room into our master bedroom. After some investigation, it proved that there was an enormous metal filing cabinet on the line-of-sight between the wireless network adapter and the access point. Moving things so that wasn't so fixed the problem.

(And, as an FYI, WEP is fairly useless. Try switching to WPA.)
posted by KathrynT at 4:10 PM on September 5, 2010


stoneweaver,

Disabling WEP does allow full connectivity, but I'd prefer to have it on, any ideas on way to work around that?


fleacircus,

Neither Windows nor Netgear's "Wirerless Assistant" would allow WEP connectivity...checking and/or unchecking the "Use Windows to configure my wireless network settings" seems to be no help.


Also, to reiterate, the dongle was working fine (with WEP enabled) for 3+ years until about a month ago.
posted by Exchequer at 4:16 PM on September 5, 2010


Sigh. So, if turning off WEP fixes it for you, you've got the same annoying problem I had. Sorry! Mine also worked fine until it didn't. The problem was annoying enough that I finally wired the house so that I don't have to deal with it anymore. I did have to switch to using the window's wireless configuration rather than netgear. I also had to switch encryption types to WPA. Try that and if it doesn't work, let me know. I have the longer instructions for when that failed saved for myself, but they're on the other computer. I will dig them up if you need them.
posted by stoneweaver at 4:26 PM on September 5, 2010


Switched over to WPA and everything's A-OK, now (laptops and desktop). Not exactly sure how that fixed things, but I'm Happy Camper.

Thanks, everyone!
posted by Exchequer at 5:04 PM on September 5, 2010


Woooo! I'm glad to hear it! If it stops working, shoot me a memail and I'll send you my whole directions.
posted by stoneweaver at 5:11 PM on September 5, 2010 [1 favorite]


I don't know if this is a feature of WPA versus WEP, but encryption can make certain forms of communication both more efficient and more robust. More efficient because encryption necessarily includes a form of compression and more robust because the protocols to decrypt the comms at the receiving end also act as a form of checksum. But both WEP and WPA are encryption protocols so in general they should both help communications. Maybe WPA is just implemented better on your hardware/drivers than WEP.
posted by kalessin at 6:40 AM on September 6, 2010 [1 favorite]


« Older Wedding reception in Bloomington, Indiana   |   When to intervene with the cat lady? Newer »
This thread is closed to new comments.