Where's the missing link?
June 29, 2010 2:40 PM   Subscribe

Blogger problem with showing links.

I have the "links" gadget at the top of my blog, and want to show all the links. I currently have three links on it, but only two are showing.

I click on the edit icon, the box comes up, and shows the "number of links to show in list: leave blank to show all links" box. I have left this box blank. All three links are showing on the editing page.

It's a problem with the number of links, not any particular link, because when I change the order of the links it keeps showing whichever two are first in the list, but won't show the third one. What gives?

Here's a link to the blog: hearthreadinggroups.blogspot.com.
posted by crazylegs to Computers & Internet (5 answers total)
 
It's there, it's just being hidden by css max-height thingy.

replace
.tabs-inner .widget ul {
...some random other stuff...
max-height:34px;

}

with

.tabs-inner .widget ul {
...some random other stuff...
max-height:68px;

}

you should be good to go.
posted by juv3nal at 2:53 PM on June 29, 2010


sorry, that's if blogspot gives you direct access to css/html.
If they have some kind GUI editor with no access to source, I don't know.
posted by juv3nal at 2:55 PM on June 29, 2010


Yep. What juv3nal said. It's max-height hiding it.

I changed it to 340px (locally) and see what it did? Boom! Missing link! Change 34px to something like 50px.
posted by nitsuj at 2:58 PM on June 29, 2010


Two things:

1. Setting an explicit height or max-height probably is not what you want if you might be adding more links. If you simply remove that max-height declaration like this:
.tabs-inner .widget ul {
padding: 2px 25px;
background: transparent none no-repeat scroll left;
}
That will work.

2. You can carry out the intent of the template designer who wanted the height to be 34px and set instead the min-height property to that 34px, so that it optimally, minimally is that height, but it can grow if the element wraps and ends up taller. So, this:
.tabs-inner .widget ul {
  padding: 2px 25px;
  min-height: 34px;
  background: transparent none no-repeat scroll left;
}

posted by artlung at 6:27 PM on June 29, 2010


Thank you all! As usual Metafilter saves the day.
posted by crazylegs at 5:33 AM on June 30, 2010


« Older language question   |   Help me sort out some final details for our San... Newer »
This thread is closed to new comments.