Fuzzy motion in MPEG Streamclip
June 8, 2010 9:03 PM   Subscribe

Why are there always fuzzy lines when I open a DVD file in MPEG Streamclip?

It doesn't seem to matter whether or not I use MPEG Streamclip's option to "fix the timecodes" before viewing.

And yet the lines are fuzzy even BEFORE I export it into another format; which means regardless of what I do, the export will be fuzzy. I've tried several encoding settings, with always the same result.

What do you suggest? Bear in mind, my computer's not the fastest, but it's not slow (2GHz intel core 2 Duo, Mac OS X 10.5.8, 2 GB memory). I'd like to export the videos, if possible, to mac-friendly formats. But it seems MPEG Streamclip can't even read the DVD without adding lines. Only when there's movement on screen. Grr!

Other things to note: This came off a Sony Handycam mini DVD recorder. I had to rip the mini DVD onto my grandmother's PC, then burn the data onto a DVD disk, so that I could then drag it only my Mac hardrive (Macs don't support miniDVDs). But if DVD Player is reading the file okay, I don't see why MPEG Streamclip would have an issue.

Is there another program that handles DVDs better than MPEG Streamclip?
posted by omnigut to Computers & Internet (8 answers total)
 
That's the source video interlacing - nothing wrong with your CPU. It's been awhile since I've used MPEG Streamclip, but there should be a "de-interlace source video" or "progressive" option.
posted by helios410 at 9:15 PM on June 8, 2010


The lines you're seeing are from an interlaced video. If I'm not mistaken, the video itself is interlaced on the DVD. You need a player or converter to deinterlace it, if you want to get rid of those lines. That might be an option in Streamclip?
posted by knave at 9:16 PM on June 8, 2010


Interlacing lines. A TV frame is made up of two fields - 1 of odd-numbered lines, 1 of even-numbered lines - transmitted & presented sequentially (i.e. Frame1Field1, Frame1Field2, Frame2Field1, Frame2Field2, Frame3Field1, Frame3Field2, …)

Computer displays aren't (usually) interlaced - instead, they're progressive, which means they combine the two fields into one frame and display that. Where you've got movement - like your scene with people moving R to L - you get the 'fuzz', as 2 interlaced fields are combined into 1 progressive frame. The 'fuzz' at the right of an object is the tail of the lines making up field 1; the 'fuzz' at the left is the leading edge of the lines making up field 2.

There's various ways around it; I forget the actual options in MPEG Streamclip but there should be some de-interlacing options like 'blend' or 'bob'. What you do with it depends on what you're transcoding / converting it to, what your target device is, etc. Rough rule of thumb: if you're editing / recoding to go onto DVD, leave it interlaced; if you're transcoding for PC / iPod / etc viewing, de-interlace it.
posted by Pinback at 9:28 PM on June 8, 2010 [1 favorite]


I'm not too good at this stuff, but the answers from an old AskMe of mine may interest you.
posted by pompomtom at 9:36 PM on June 8, 2010 [1 favorite]


THANK YOU.
posted by omnigut at 9:43 PM on June 8, 2010


Yep. Interlacing. It's the 'i' at the end of resolution names like 1080i, or 480i (which is what we've retroactively named the basic analog TV resolution).

DVD Player almost certainly automatically deinterlaces video. Streamclip, apparently, does not.
posted by Netzapper at 9:45 PM on June 8, 2010


The lines will become less fuzzy if you choose "Resize to Full frame" in Streamclip's Window menu. That way you'll see that they alternate precisely every other line.

As others have said, you'll need to turn on the "Deinterlace" options when exporting to get rid of them.

Interlacing is a surprisingly complex topic, and worth trying to understand.
posted by Mwongozi at 11:03 PM on June 8, 2010


Thanks for asking this. I'd experienced this for years, and had never bothered to ask anyone why it happens. I thought that it was just something to do with my own hardware.
posted by jpcooper at 1:02 AM on June 9, 2010 [1 favorite]


« Older I Screwed Up My Marriage   |   Is my blender broken? Newer »
This thread is closed to new comments.