Fixing fonts in Opera and Chrome
May 14, 2010 1:09 AM   Subscribe

Argh! What's happened to my fonts in Opera on linux?

Using Ubuntu, Opera has just updated to version 10.53. And the fonts look horrible. Thin, spidery. In fact, almost as bad as the fonts on Chrome. Firefox fonts look fine. How can I fix the fonts on Opera and Chrome?

I've created an example on Dropbox. The picture shows Opera 10.53, Firefox 3.6 and Chrome in order, redering The Guardian.
posted by salmacis to Computers & Internet (8 answers total)
 
Mind you, that is still a beta.

What fonts do you use in each of the browsers?
posted by noztran at 1:52 AM on May 14, 2010


Deja Vu Sans.
posted by salmacis at 1:57 AM on May 14, 2010


Maybe opera isn't using the xft backend. Open a new tab and go to this address:

opera:config#UserPrefs|EnableXftFonts

See if enabling/disabling the checkbox (and probably restarting opera) gives you something you like.
posted by Dr Dracator at 8:03 AM on May 14, 2010


Nope, that's not it.
posted by salmacis at 8:33 AM on May 14, 2010


I find the font hinting in recent Ubuntu (where recent is anything newer than 8.04) awful. To fix it I replace ~/.fonts.conf with:
<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
  <match target="font">
    <edit name="antialias" mode="assign">
      <bool>true</bool>
    </edit>
    <edit name="hinting" mode="assign">
      <bool>true</bool>
    </edit>
    <edit name="hintstyle" mode="assign">
      <const>hintfull</const>
    </edit>
    <edit name="lcdfilter" mode="assign">
      <const>lcdlegacy</const>
    </edit>
    <edit name="rgba" mode="assign">
      <const>rgb</const>
    </edit>
  </match>
</fontconfig>
And I append the following to ~/.Xresources:
Xft.antialias:  true
Xft.hinting:    true
Xft.hintstyle:  hintfull
Xft.lcdfilter:  lcdlegacy
Xft.rgba:       rgb
Your mileage may vary.
posted by togdon at 8:36 AM on May 14, 2010


I actually had something like that already, togdon. The fonts in Ubuntu are generally fine - it's just the latest version of Opera, which seems to have downgraded to be almost as unreadable as Chrome.
posted by salmacis at 12:44 AM on May 17, 2010


For anyone googling this answer, I've stumbled upon the answer for Chrome, at least. The trick is to use togdon's suggestion above, but use hintstyle=hintslight instead of hintfull. Probably Opera can be improved by changing the font hinting as well.
posted by salmacis at 2:02 AM on May 24, 2010


Really I think that the key is:
      <const>lcdlegacy</const>
regardless of what hintstyle you prefer. Essentially you're saying with that line in your config: "Dear Ubuntu: Your new hinting style makes vertical lines look like ass, and you don't give me a slider or a checkbox to undo that."
posted by togdon at 2:46 PM on May 24, 2010


« Older Are iPads and tablet PCs viable substitutes for...   |   How to set up a political party in Australia? Newer »
This thread is closed to new comments.