A man can't be too careful what he signs these days...
April 27, 2010 1:27 PM   Subscribe

Why won't Apple Mail let me attach a signature to my emails?

Having decided to put on a veneer of grad school professionalism, I made a signature for myself for use in Apple Mail. It's nothing fancy; there's no HTML or any images. It's just my name, title, address and phone number. I access a Gmail account and a university account through Mail, so I created two identical sigs, one for each account.

Now the pulldown signature menu appears with each blank email I open, but it's stuck on the default "None." No other options appear on the pulldown. I've Googled around, and I'm confident that I have all the signature settings set correctly---on the signature menu, each account has the correct sig assigned to it, not "None." I've even restarted my computer a few times since I first tried setting this up, and nothing's changed.

So what am I doing wrong?
posted by Bromius to Computers & Internet (7 answers total)
 
I don't know which version of OS X you're running, but on mine (10.6.3), the Signatures pane under Mail Preferences lets you add signatures under different accounts. As in, you can have a signature that is selectable under all your accounts, or a specific signature for your personal/work e-mail, etc. Is it possible you've created your signature under a different account?
posted by jaffacakerhubarb at 1:33 PM on April 27, 2010


I don't have it in front of me right now, so bear with the description, but in the Signatures pane on the far left there should be two items - one is something like "all signatures" and the other should be your name. Make sure the new signature you created is in the folder under your name, not just "all signatures". You'll know it's in the right spot if it shows up on the "make default" dropdown at the bottom of the pane.

(On preview, same as above)
posted by Fifi Firefox at 1:36 PM on April 27, 2010


The Signatures pane on the left has:

All Signatures (2 signatures)
Gmail (1 signature)
University (1 signature)

For each of the two accounts, the signature is correctly specified via the Choose Signature bar. Under All Signatures, however, the Choose Signature bar is grayed out, set to none, even though both signatures are visible in the list.
posted by Bromius at 1:49 PM on April 27, 2010


Oh and sorry! I should say I'm running OS X 10.5.8 and Mail 3.6.
posted by Bromius at 2:00 PM on April 27, 2010


I am using OX X 10.6.3
and Mail 4.2

Signature pane under mail preferences will have a "all signatures" entry, which is effectively greyed out as you mention.
But if you choose the actual signature, then the "choose signature" drop down menu comes to life. give this a try.
posted by theKik at 4:35 PM on April 27, 2010


When you say "choose the actual signature," what do you mean? Selecting the signature from the center panel? When I do this, nothing changes. The only time the "choose signature" menu works is when one of the specific mail accounts from the left panel is selected.
posted by Bromius at 7:07 PM on April 27, 2010


I think what theKik is saying is that, from the "All Signatures" list, you're unable to actually choose a signature, like so : http://grab.by/48jj

What you need to do instead is select the accounts themselves, and THEN use that dropdown box, like so : http://grab.by/48jg

Hopefully that'll do it.
posted by revmitcz at 9:10 AM on May 1, 2010


« Older Cool Tenant Wanted   |   Animated Shorts Filter, help with my nostalgia! Newer »
This thread is closed to new comments.