Can I include a non-printing page in a Word 2003 document? If so, how?
April 15, 2010 10:41 AM   Subscribe

Can I include a non-printing page in a Word 2003 document? If so, how?

I am creating a word template for general use across my company. It's been requested that the first page of the template be a non-printing page containing instructions on template use. How can I accomplish this?

I did find this post about non-printing text. Chunder's highlighted suggestion would have me making the instructional text hidden but visible. This is halfway to a good solution, but the page with the hidden text still prints, albeit as a blank page. I don't want a blank page to print!
posted by kitcat to Computers & Internet (15 answers total) 3 users marked this as a favorite
 
As a kludge -- put the logo of your company and the title of the template at the top center of the first page, with the non-printing instructions below it. That way, when someone prints it, it'll just look like a cover page.
posted by Etrigan at 11:10 AM on April 15, 2010


Etrigan: Hmmmm, clever. That might just do the trick.


I'm still looking for a 'proper' solution, so don't refrain from posting if you have one.
posted by kitcat at 11:22 AM on April 15, 2010


At my office, the template instructions were in a colored/italicized text and the first line of the instructions was 1. DELETE these instructions.
So, yeah, we had a lot of documents with the instruction page printed in them. Sorry.


Hey, is it possible to set the default printer settings so it would automatically print page 2-20 instead of 1-20?
posted by CathyG at 11:51 AM on April 15, 2010


I think I found the fix: http://www.keyongtech.com/3610592-create-non-printing-pages-in

Make sure you read it all the way through to find the link to the true solution (as well as the fix of the typo) down towards the end of the conversation.
posted by StarmanDXE at 12:16 PM on April 15, 2010


The templates I've always seen have a "DO NOT INCLUDE/PRINT THIS PAGE" across the top in bold, red print. A human solution and not a technical one.
posted by Big_B at 12:31 PM on April 15, 2010


Thanks StarmanDXE!

I've also found another solution that doesn't require any coding. It comes from this page and I've bolded the key info below:
You can select everything on the page and format its font as Hidden.
In the Options dialog, set the on-screen view to display Hidden text,
but set the printing option to *not* print Hidden text (that is, clear
the checkbox for that one).

As long as there are no hard page breaks or other things to force a
new page, the printed version (in both Print Preview and the paper
output) will behave as if the Hidden text isn't there.


Regards,
Jay Freedman
Microsoft Word MVP FAQ: http://word.mvps.org
I've discovered that order to really make this work, the non-printing text has to take up the entirety of the page it's on - otherwise the text on the next printing page won't be properly positioned at the top of its page. So if there isn't enough hidden text to take up a whole page, you need to include something as insignificant as a period on the last line of that page so as not to throw positioning off the in the rest of the document.

Thanks for everyone's help - it looks like there are several ways to do this and it's good to know what they are.
posted by kitcat at 12:49 PM on April 15, 2010


Yeah, but that doesn't work. Check out this comment from the OP of the link I posted:
Ah-hah! Yes - the first page - instuctions including a logo, call-outs etc,
all took the "hidden" formatting - to my amazement - and when I hit my print
button only page two - the actual form- came off the printer. I even tried
it with Tools - Options - View - Hidden Text checked AND unchecked, and both
ways I was able to see both pages and print only the second. Feeling oh so
victorious, I took it to the form's author, and when she tried to set it up
with the hidden text, it all disappeared! That's when I realized that on my
system, I have Tools - Options - View - ALL checked - which is NOT the
standard setting for the literally hundreds of people who will be required to
use the form, and changing the setting on everyone's PC doesn't seem to be an
option. RATS!!
Thank you so much for your help - guess we'll be burning
paper after all...
Therefore, I recommend doing it the macro way ;-)
posted by StarmanDXE at 1:06 PM on April 15, 2010


Rats indeed!

Yup. I thought that, because the document is a template, the View - Hidden setting would migrate with it, but no (I checked with a colleague, just like the poor soul above). My company's small enough that I could get the 10 or so people who will use the template to turn on View - hidden - but this is definitely not ideal.

Deep sigh.
posted by kitcat at 1:26 PM on April 15, 2010


What about a macro that could turn on the Tools > Options > View - Hidden setting? Anyone? To me, this is preferable to mucking with the printing.
posted by kitcat at 1:28 PM on April 15, 2010


You can do that with a macro, and in fact I just did, but Word isn't going to run it without the user's explicit request or permission, and the macro will probably be disabled by default. This is because viruses can use the functionality to spread.

Admittedly, I have Word 2007 on my machine and not Word 2003. Word 2003 may be more lax about it. To check it out, add the Document_Open handler below to your document.

Private Sub Document_Open()
    ActiveWindow.View.ShowHiddenText = True
End Sub


To do this, follow these steps:
  1. Press Alt-F11. The VBA editor opens.
  2. In the browser in the top left corner of the VBA editor window, under Project > Microsoft Word Objects, double-click ThisDocument. An edit window appears.
  3. In the top of the edit window, change the left pop-up menu to say Document and the right pop-up menu to say Open. A Document_Open handler appears in the window.
  4. Edit the Document_Open handler so it looks like the above.
  5. Close the VBA editor (not just the edit window, but the enclosing VBA editor window).
  6. Save your Word document.
Now go to the options and turn off the hidden text setting. Close the document and re-open it. If you don't see any warnings, check the hidden text setting to make sure it has been turned on. If it has, you're golden.
posted by kindall at 3:16 PM on April 15, 2010


D'oh, I should have noted that those steps above should be started in Word with the document active that you want to attach the macro to.
posted by kindall at 3:17 PM on April 15, 2010


There you go:
Sub AutoOpen()
ActiveWindow.View.ShowHiddenText = True
ActiveWindow.View.ShowAll = true
End Sub

There also exists an AutoNew() procedure which comes in handy with templates.

On preview, what kindall said. AutoOpen() definetively works with Word 2003.
posted by mmkhd at 3:26 PM on April 15, 2010


Fantastic!

I have one last question, if anyone's around to answer. Will running the macro once change the user's Hidden Text setting for good - that is, will the setting persist even after their document based on my template is saved and closed and they are working on other things in Word? Or will it revert back, requiring that the macro be run each and every time they work on a document based on my template?
posted by kitcat at 9:30 AM on April 16, 2010


The setting is persistent, but since the user can turn it off, I would advise embedding the macro into each document you create that needs this feature.
posted by kindall at 11:08 AM on April 16, 2010


Final Note:

The macro only seems to run automatically if I change the event from Document_Open() to Document_New().

I'm not clear on why, although this (source) may explain it to those more savvy than I:
A Document_New() procedure will run when a document based on that template is created; a Document_Open() procedure will run whenever a document based on that template is opened...
Thanks Kindall and mmkhd! Everything seems to be working now.
posted by kitcat at 12:51 PM on April 16, 2010


« Older TESL certification from Duke: Hot or not?   |   Biography on William Henry Harrison? Newer »
This thread is closed to new comments.