Courier-IMAP vs Outlook
February 11, 2005 12:52 PM   Subscribe

Non-Googlable tech support! I have a friend doing hosting off courier-imap. I am forced to use Outlook 2003 as a client. With Outlook, no matter which machine I go to, I cannot access my IMAP account and only return an error (detailed inside) about Outlook is unable to download folder (null). Here are links of people with the same problem but no solutions, 1, 2, 3.

This has been driving me mad as it has a tendency to come and go. I am able to use my mail find in Thunderbird and the web-based SquirrelMail. Outlook is no go no matter what computer it is on or what ISP I'm connected to. Here's some basics:

- Outlook 2003
- Windows XP Pro (using both SP1 & SP2)
- All account settings are fine, working
- If I use a different account in Outlook it will work, then stop working at random intervals
- Problem is sporadic enough to drive me crazy

My host says IMAP is working fine, but not playing well with Outlook 2003. Any solution besides using POP3? This seems to be a problem that's not being addressed and I can't believe MS would not support IMAP. I appeal to you, Metafilter.

Actual Error Message:
Task 'Checking for new mail in subscribed folders on' reported error (0x8004DF08) : 'Outlook is unable to download folder (null) from the IMAP e-mail server for account Error: The connection to the server is unavailable. Outlook must be online or connected to complete this action. If you continue to receive this message, contact your server administrator or Internet service provider (ISP).'
posted by geoff. to Computers & Internet (9 answers total)
Response by poster: I'm able to use my mail FINE ... not find.
posted by geoff. at 12:53 PM on February 11, 2005

Is this unencrypted IMAP, IMAP+SSL or IMAP+TLS?

Are you running any antivirus programs on these machines?

I'm not an Outlook user (anymore), but I believe it has an option to write debug information to a log file. If so, that could help you diagnose the problem.
posted by gentle at 1:56 PM on February 11, 2005

I have the exact same setup. Courier-IMAP on my home server works fine using TBird, SquirrelMail, etc, but Outlook (in this case, Outlook 2000) chokes with the exact same message as soon as my fiancee tries to connect to the server to check her mail.

After going through a few possible solutions (and finding no help from anyone online, might I add) I eventually just threw up CourierPOP for her to use on the internal network, then firewalled off the POP3 port and told her to use SquirrelMail while she's on other networks (she didn't want to migrate to Thunderbird). Courier-POP plays nicely with Outlook, apparently.

I would much prefer to go pure IMAP, so I hope someone here knows the answer to this question. I can't imagine that Outlook connecting to Courier-IMAP is a rare combination...
posted by DoomGerbil at 2:51 PM on February 11, 2005

Hmmm... curiously enough, mine works fine with Outlook 2003. I just installed it and away I went, no hangups.

What's your folder structure look like? For example, in my home directory I have ".maildir", which is also my inbox. Inside that I have all my subfolders (so everything is a subfolder of Inbox). I used the Courier-IMAP 'maildirmake' command to set this all up.

In my config file I have the parameters:


I'm wondering if you have some odd folder hierarchy that Outlook doesn't like, or if you administrator has bad values for those two parameters. Just a guess.
posted by sbutler at 4:51 PM on February 11, 2005

Google groups suggests it might be rate limiting (if you have multiple accounts). That could be either the microsoft bug mentioned or your isp, although I would doubt the latter.

Another post suggests somewhere to look for in your account settings, potentially for a place to specify the default folder? I don't have outlook here to try, unfortunately.

If you're technically able, you can get a good packet sniffer and see what really goes on with the connection. Maybe it really is a bug with outlook, or even with courier-imap. Access to the latter's logs would certainly be useful so you can see what the server gets from its side. Again, a packet sniffer on the imap server side would be useful if you can interpret the data.

Maybe there's a firewall issue? Who knows. That's the whole fun of debugging strange problems with no obvious solutions :)
posted by splice at 4:54 PM on February 11, 2005

Outlook's IMAP support has an option to specify the path of the inbox -- it's Root folder path in the Advanced tab under the IMAP account settings. By default this is blank, ie. not set; you could try setting it to INBOX, which is required by some servers.

I use the Dovecot POP/IMAP server with maildirs. Open source, written from the ground up using "modern" security concepts and performance optimizations. Highly recommended.
posted by gentle at 5:06 PM on February 11, 2005

I've had problems with numerous clients if the maximum connections per IP was too low. Courier defaults to a low number usually (MAXPERIP in the imapd config file; location is /etc/courier/imapd in Debian). I think it's default set to 4 in some releases. If it can be bumped up to 10 that'd probably do the trick.

Or get your friend to install Dovecot.
posted by zsazsa at 11:53 PM on February 11, 2005

Response by poster: MAXPERIP is set to 12... having it raised to 20.

I can't believe I didn't think of Ethereal. As soon as I downloaded it and set it to catch everything Outlook mysteriously started to work. So frusterating! Well next time it happens I'll be prepared and update everyone here.

Specifying the default folder does not help either.

I'm somewhat confident that MAXPERIP is the stickler, though having 12 users from my IP is a little suspicious.
posted by geoff. at 10:51 AM on February 14, 2005

Response by poster: If anyone cares, I ran ethereal:

Apparently Outlook is trying to create a "Junk E-Mail" folder in the INBOX heirarchy. This causes the server to bonk out for whatever reason. Junk E-Mail filtering is off everywhere I can find it. Problem still occuring sporadically.

Investigation continues...
posted by geoff. at 1:16 PM on February 16, 2005

« Older putting line breaks in long URLs. Make it...   |   Skaters Sneakers Newer »
This thread is closed to new comments.