OSX, Ubuntu and 7 OH MY! Permissions hell awaits.
April 1, 2010 6:10 PM   Subscribe

Mac OSX 10.6, Windows 7 and Ubuntu 9.10 are not playing nice in the area of permissions. Please help us hivemind nerds. More after thee jump.

Our server that is running Ubuntu is currently operating as our NAS. We have Win 7 and Mac OSX machines that are creating files that are stored on said Ubuntu machine across the network. Lately I (mac user) have been having problems getting a lot of access denied / permissions errors. Our It person who helped get this running is at a loss as well. He gave me this info to pass along-

Ubuntu File Server Setup.

Samba Security is setup as:
"User"

Share Directory Masks:
Create Mask: 0660
Directory Mask: 0771

Owner and Read Write Permission setup:
chown -R root:users /media/NAS_Disk-2/graphics-nas
chmod -R ug+rwx,o+rw /media/NAS_Disk-2/graphics-nas

There has to be an easier way than running a script every night to give read / write permissions to every file on the server. Maybe it's something with the mac creating permissions that are causing problems after the files are transferred. Win 7 users have trouble sometimes too. Any help is appreciated and I hope I have explained this well enough to get some feedback.

Thanks to all in advance!
posted by pleuroma to Computers & Internet (3 answers total) 3 users marked this as a favorite
 
I thought in the list of fixes in the 10.6.3 update this week there was a blurb about fixing some networking issues. Unless you did the update this week and it started the problem.
posted by birdherder at 6:17 PM on April 1, 2010


No. I actually did the update this week and it didn't seem to change anything that I have noticed as of yet.
posted by pleuroma at 8:38 PM on April 1, 2010


Are you sure that all the users who are accessing this share are actually in the "users" group?
because a create mask of 660 is going to ensure that only the original file owner and anyone in the same group as the original owner are going to be able to read or write to the file in question.

But since I see you're apparently chmod'ing everything 776 anyway (which is an odd choice of permissions to use), you'd be better off just setting the create mask to 666 and the directory mask to 777 - which would by default make all files both readable and writeable by anyone, and make directories traversable by anyone. THIS IS BY NO MEANS SECURE but security and samba and file permissions is an entirely separate topic.
posted by namewithoutwords at 6:53 AM on April 2, 2010


« Older Restoring a Windows 7 System Image from an...   |   What are Personality Comics like? Newer »
This thread is closed to new comments.