Firefox 3.6 showing up as older version?
March 8, 2010 10:50 AM   Subscribe

I'm running Firefox 3.6 on my Mac (OS X.6.2). Yet when I try to load extensions that work on versions 3.5 & higher, they say I need to upgrade my browser. One extension had the following error message: "______" could not be installed because it is not compatible with your Firefox build type (Darwin_x86-gcc3)." Also, youtube is claiming that I'm running a version of Firefox that will soon be incompatible with their website. What gives? Why does everyone think I'm running an older version of Firefox, and how do I fix this?
posted by ericbop to Technology (12 answers total)
 
Best answer: Are you running a custom build of Firefox, or something downloaded straight from Mozilla? What does "What's My User Agent?" tell you?
posted by WCityMike at 11:07 AM on March 8, 2010


Response by poster: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/2.0

I remember downloading something a long time ago that was supposed to be a version of Firefox customized for the Mac. But I can't remember what it was called (I know, lame). Could that be the problem?
posted by ericbop at 11:15 AM on March 8, 2010


When you get info for Firefox what does it say? Right now that webpage is showing you running Firefox 2.0.

Do you have an alias pointing to the old version of Firefox?
posted by OmieWise at 11:27 AM on March 8, 2010


What I would do is completely remove Firefox. Follow these directions. First backup your bookmarks and any other information you might want to keep, like saved passwords and extensions (you don't have to actually delete the files but could temporarily move them to your desktop). Download latest version of FF. Install that. With the plist files and Application Support folder removed when you open FF it will be as if you did it for the first time. I suspect that will fix things. If it does you can restore your bookmarks. You'll have to add back any extensions and log into your websites again.
posted by 6550 at 11:28 AM on March 8, 2010


Do not follow 6550's instructions quite yet; that's pretty much the nuclear option. Let others see if they can help you first.
posted by WCityMike at 11:29 AM on March 8, 2010


ericbop: I remember downloading something a long time ago that was supposed to be a version of Firefox customized for the Mac. But I can't remember what it was called (I know, lame). Could that be the problem?

Type "about:config" into your address bar. If it gives you a warning, click past it. In the "filter:" bar, type "general.useragent.override". Does it come up with a value? If so, right-click on the line it showed you, and pick "Reset." Quit and re-open. Do you still have the problem?
posted by WCityMike at 11:37 AM on March 8, 2010


I remember downloading something a long time ago that was supposed to be a version of Firefox customized for the Mac. But I can't remember what it was called (I know, lame). Could that be the problem?

I don't know if it's the cause of your problem, but sounds like Camino? I have no idea what user agent string Camino would generate though.
posted by juv3nal at 12:08 PM on March 8, 2010


It's not necessarily Camino. I remember there being some "optimized" versions of Firefox floating around. I downloaded one at one point that supposedly had the configurations tweaked to run better on Mac.
posted by OmieWise at 12:11 PM on March 8, 2010


Best answer: are you using the "User Agent Switcher" extension? If so, change you settings so that it's identifying itself as Firefox 3.6 (Default User Agent).
posted by chrisamiller at 1:17 PM on March 8, 2010


I'm getting the exact same response as you from the user agent checker with the exception of Fx version. You should be reporting as 3.6, especially with a Gecko engine dated 2010-01-15. That wouldn't be included in 2.0.

Check your user agent settings per WCityMike and chrisamiller's suggestions. If that doesn't do it, try starting in Safe Mode to see if it's an add-on error.

(Run /Applications/Firefox.app/Contents/MacOS/firefox-bin -safe-mode in a Terminal window to open in Safe Mode.)

Next step would be to check whether it's a profile error - go to /Users/(your user)/Library/Application Support/Firefox/Profiles and move or rename the existing profile folder, which should be named (8 random characters).default - easiest is to change it from "abcd1234.default" to "abcd1234.old", or similar. Then start Fx again - it will create a new blank profile. If the problem is fixed, you probably need to rebuild your profile.

If none of the above work, THEN nuke it from orbit.
posted by caution live frogs at 1:34 PM on March 8, 2010


Response by poster: Thanks for the help, everyone! I downloaded and installed "User Agent Switcher," and created a custom agent with Firefox 3.6 as the version. Now youtube, extensions, etc. load just fine! I'm still not sure why I was having a problem in the first place, or why I have to spoof my browser to show the correct version, but at least the problem is solved! The one thing that still won't install is the Keefox extension, which is still claiming that it's not compatible with my Firefox build. But this must be a separate problem, and not related to my version number.
posted by ericbop at 5:57 PM on March 8, 2010


Hrmm - I suggested User Agent Switcher as the cause, not the fix, but I'm glad to see it worked for you.

If you experience more problems, you might consider starting a new profile, migrating your bookmarks, history, and passwords over, then reinstalling the addons that you use from scratch. >95% of firefox weirdness can be traced back to addons gone awry.
posted by chrisamiller at 12:26 AM on March 9, 2010


« Older QR codes to organize my life   |   Best Link Outlet? Newer »
This thread is closed to new comments.