The cursor on my MacBook jumps around like crazy.
February 8, 2010 8:00 PM   Subscribe

When typing, my cursor jumps around like crazy, highlighting paragraphs, jumping back words, and making it impossible to type normally. MacBook4,1 (whatever that means), Mac OS X 10.5.8 (9L31a).

I have searched high and low for what this could be, and only come up with one or two mentions of it, with no real resolution. To give you an example of what happens, here is the first sentence rewritten without correction:

normally.When typing, my cursor jumps zy, highlighting paargraphs, jumping back words, making it impossible to typeararound like cr
posted by Optimus Chyme to Computers & Internet (19 answers total) 1 user marked this as a favorite
Does it do this when you take excessive care not to touch the touchpad, such as holding your hands way up off the wristrest?
posted by majick at 8:03 PM on February 8, 2010

Yes, are you possibly brushing the touchpad when you're typing? I do this when using my Lenovo and it drives me crazy. When I'm typing for any length of time, I disable the touchpad to stop this from happening. Maybe there's some way to decrease its sensitivity; I don't know.

If I used my laptop more frequently I'd probably keep the touchpad disabled and use an attached mouse instead.
posted by ZeroDivides at 8:04 PM on February 8, 2010 [1 favorite]

Are you resting your wrists on the touchpad?
posted by mollymayhem at 8:05 PM on February 8, 2010

Doh! Previewfail.
posted by mollymayhem at 8:05 PM on February 8, 2010

i had to turn tapping off on the touchpad to get rid of this some years ago. maybe there's a better solution now.
posted by rhizome at 8:08 PM on February 8, 2010

In System Preferences->Trackpad, is "Ignore accidental Trackpad input" checked? That's the Mac equivalent of "Disable trackpad while typing" under Windows.
posted by Cat Pie Hurts at 8:26 PM on February 8, 2010

Response by poster: Sometimes it happens all the time for an hour or two, sometimes it just goes away. I have done tests and watched it happen even with one-finger typing, but I cannot find a pattern other than that it seems to frequently happen when I type the letter "a." I'm wondering if control, option, or command are stuck, but again, no pattern other than the "a" thing.
posted by Optimus Chyme at 8:30 PM on February 8, 2010

Response by poster: In System Preferences->Trackpad, is "Ignore accidental Trackpad input" checked?

posted by Optimus Chyme at 8:31 PM on February 8, 2010

You don't have any bluetooth input devices (mouse or keyboard) that might be turned on and hidden somewhere within range, do you? (A long shot, but this happened to a friend of mine and boy did she feel silly at the Apple Store).
posted by MadamM at 8:34 PM on February 8, 2010

Do you have trouble clicking the trackpad button? Does it fully depress and then pop back up? I had this situation a few months ago (right around finals, argh!) and had to take my Mac in to the store to get the plastic cover replaced (and then again a month later). Here's how I've dealt with the problem short-term:
-Only use the computer on a flat surface. Don't put it in your lap.
-When it starts to get all wonky, pick it up and shake it around a little. Sometimes that helps dislodge whatever's stuck.
-Toggle the command key. Sometimes it thinks I'm pressing command when I'm not really, and so everything is an automatic right-click.
-Take the battery out of the computer. The battery can sometimes place extra pressure on the plastic case and cause these strange issues.

This issue seriously sucks, and it's likely only going to get worse. You should try to find someone to fix it now rather than trying to find a workaround.
posted by lilac girl at 8:39 PM on February 8, 2010

I have a MacBook from early 2007 which has suffered from similar symptoms. In my case, the problem is the crappy design of the trackpad button. The button will sometimes make intermittent contact without being pressed, usually as a result of applying pressure to nearby parts of the laptop case. The problem is worse when the laptop is warm.

I have mostly fixed this problem by using a wad of paper to create more space between the button housing and the battery. This may point you in the right direction.
posted by Galvatron at 8:41 PM on February 8, 2010

Not relating directly to your problems, but a short time ago I was experiencing problems where my cursor would randomly jump around when I was zoomed in. Curiously enough, pairing my MacBook Pro with a Magic Mouse has fully fixed this issue and I've yet to experience it since. :)

So, if you have a friend with a Magic Mouse, try pairing it up with your MacBook then seeing if that helps.
posted by 47triple2 at 8:57 PM on February 8, 2010

stupid question-- are you using a space heater? Or near a source of forced hot air? My mac laptop's cursor gets unpredictable if I have the heater in my office pointed just the wrong way.
posted by Mayor Curley at 8:57 PM on February 8, 2010

Response by poster: are you using a space heater?

No, it's cold. I think Galvatron and lilac girl are on the right track, as I've had to run an index card along the seam between the trackpad and button to remove detritus so it could work properly.
posted by Optimus Chyme at 8:59 PM on February 8, 2010

Maybe you could use as mouse for a while to eliminate trackpad interaction, and see if this still happens?

Also not directly related, but as 47triple2 says, MacBook Pros have a similar problem. In my case the problem manifested itself as the cursor being 'stuck' to the tops of windows, and thus dragging them around the screen. I couldn't 'drop' the window. It was weird. Maybe this is happening to you with blocks of text (i.e. you are unintentionally highlighting blocks of text and then dragging them around)?

I think Apple trackpads are problematic. With MBPs it is also something to do with the battery pressing against the back of the trackpad. FWIW the trackpad now comes with an internal screw that you can use to adjust the pressure sensitivity of the trackpad; so you don't need the paper shim trick.

I adjusted my MBP trackpad using the screw but it is still glitchy. I find it helps to be precise where I press on the trackpad when I am working. Clicking on different parts of the trackpad calls up different commands and cursor behaviour, which appear to me to be random.
posted by carter at 9:26 PM on February 8, 2010

A bit of an extension of what carter said (I have a MBP so I'm not sure its relevant) but after a few year (first gen MBP) my battery got warped. This caused it to push up into the trackpad and cause similar symptoms to yours.

I'm not sure if MacBooks have run into the same issue YMMV
posted by bitdamaged at 10:38 PM on February 8, 2010

Only time I have seen this happen was when using an external mouse. Some (especially the $10 Microsoft mice) are just glitchy when used on a Mac and can cause random cursor jumping. The $20 Intellimouse never did it, just the cheap "basic" mouse. If you are not using an external mouse, ignore. But if you have an external around, try the setting that shuts off the trackpad when a mouse is present - it should at least let you use the computer until you can get the trackpad fixed.
posted by caution live frogs at 9:41 AM on February 9, 2010

I've had this happen. Either the touchpad sensor is broken or you have a usb mouse plugged in.
posted by 2legit2quit at 10:23 AM on February 9, 2010

i don't use a mouse (only the trackpad) & i have a windows laptop, but my cursor does the same thing. drives me nutz. sometimes when i'm typing the words come out in reverse (ie ni esrever). grrrrr. people think i'm crazy but it happens quite frequently & it's very aggravating.
posted by msconduct at 10:52 AM on February 9, 2010

« Older elderly memoirs   |   I don't know art, but I know what makes my water. Newer »
This thread is closed to new comments.