Almost saved by Linux
February 3, 2010 1:47 AM   Subscribe

Help! Speaker sound on laptop, with Ubuntu for Panasonic CF-T8..

I am on Holiday, and Window install shat itself. I put Ubuntu on a USB Stick to boot to keep me going, but kids use it to watch the occasional movie. Alas, I can not get sound through the speakers. The headphones work just fine.

I am not sure what to do, or even if I can fix it. I followed the suggestions to re-get the latest alsa with apt-get, and tried various settings in /etc/modprobe.d/alsa-base.conf. For example:

options snd-hda-intel model=thinkpad

as well as "auto", "panasonic", "laptop" and "3stack". Some works great with head phones, but none gets the built-in speaker to work. I have a Panasonic Let's Note CF-T8 laptop.

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Subsystem: Matsushita Electric Industrial Co., Ltd. Device 8338
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- SERR-
Capabilities: [130] Root Complex Link <>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

Soon I will be without Internet access, so hoping someone will have some assistance. I have fiddled with all volumes in alsamixer, gtk-alsamixer, Ubuntu-system/setting/Sound. It works with headphones plugged in, just not the speaker.

Hope me!
posted by lundman to Computers & Internet (7 answers total)
You've worked systematically through this page, I suppose? If so, can you post the link that generates?
posted by flabdablet at 4:50 AM on February 3, 2010

I have an snd-hda-intel card too. Go to a terminal and do `alsamixer` scroll to the far right using the arrow keys and there may be a Speaker bar. Hold the up arrow until it gets to the top and make sure it says 00 underneath instead of MM.
posted by DJWeezy at 5:14 AM on February 3, 2010 [1 favorite]

Stupid question...but have you made sure the speakers are not muted? I noticed after I upgraded to Ubuntu 9.10 that the speakers default to muted after a boot.
posted by COD at 5:46 AM on February 3, 2010

In a terminal, run alsamixer. There are often mixer elements for sound cards that are not available in other mixers, but alsamixer allows access to just about every part of the sound card that the alsa system can set.
posted by idiopath at 10:38 AM on February 3, 2010

Response by poster: Yeah, been through the alsamixer, which changes with each model=XXX choice I go for, but only headphones work. No speaker yet.

posted by lundman at 11:16 AM on February 3, 2010

OK, you're currently using 3stack-dig so presumably your machine does have SPDIF. You've tried laptop. Have you tried laptop-dig?
posted by flabdablet at 5:04 PM on February 3, 2010

Response by poster: It mentions Digital, but there is no SPIF plug directly. Lineout and mic. Still no speaker sound, and I have tried all those mentioned. Oh well..
posted by lundman at 12:42 AM on February 5, 2010

« Older Should I get rimless glasses?   |   Donate to Charity with Affiliate Links Newer »
This thread is closed to new comments.