Firefox keyboards, É?
January 27, 2010 11:58 AM   Subscribe

I accidentally installed Firefox while my default keyboard was not English. I have switched everything I can think of to English default, but Firefox keeps giving me a French keyboard. How can I make it stop?

I haven't noticed any particular trend. Sometimes twitter, or mail, or a new tab will be in English, sometimes in French. It seems to switch even within a session but I could be mistaken. Different tabs have different language settings.

I turned off all input setting changes, so the only keyboard shortcut I have is to switch to an English keyboard. I do not have a keyboard shortcut to switch between layouts, I need to do that using the mouse.

I do not intend to reinstall Firefox to solve this, since it's annoying but not that hard to change. I do not recall this happening in any text editing or word processing program.

I am using Windows 7 and Firefox 3.6.
posted by jeather to Computers & Internet (13 answers total)
 
I do not intend to reinstall Firefox to solve this...

Not to be a jerk, but downloading and installing Firefox again would take less time than it took you to type this question. Like, a minute?
posted by rokusan at 12:12 PM on January 27, 2010


Did you see this fix?
posted by bwonder2 at 12:15 PM on January 27, 2010


If you install Firefox while using a French keyboard (or while the language of the OS is French), it may default to the French version of the program or it may just put French as the preferred language for websites that have multiple choices.

If the Firefox menus, tools, etc. are in French, you'll have to reinstall an English version of Firefox, because the program itself is in French. If it's only some webpages that are in French - but the menu up top says stuff like "File" and "History" - your problem is that for websites available in multiple languages, Firefox is choosing to use French. That's easy to fix: Open up the Firefox options/preferences (probably under "Tools" but possibly under "Edit" or "File.") Go to the set of options under "content." You'll see an option for language. Click that, and you should get a list of which languages webpages should use. French will be on top. Delete it, and leave the English entries. Any websites in multiple languages will now default to English.

(I'd give slightly more detailed description of where in the peferences this option is, but I'm using a German copy of Firefox on a Mac...)
posted by ubersturm at 12:22 PM on January 27, 2010


The menus etc are in English, not French. I only have en-gb and en as possible languages that websites use.

The fix there suggests that I am using keyboard shortcuts to switch languages, but I do not have any keyboard shortcuts enabled to switch between languages, because I disabled them. (That would have been alt-shift, I think. Testing it shows no change in keyboard language.)

I have other reasons for not wanting to reinstall Firefox, and if need be I will just keep switching back to English, it's just nigglingly irritating.

Of course, since I posted every new tab has happily used English.
posted by jeather at 12:29 PM on January 27, 2010


Are you sure the problem is with Firefox, and not with Windows' language input?
posted by KokuRyu at 12:38 PM on January 27, 2010


I'm not positive, but it seems to only be a problem in Firefox, and not other programs which I type into, notepad, OpenOffice, IE, etc. I'm having a hell of a time figuring out where and when the keyboard changes.
posted by jeather at 12:41 PM on January 27, 2010


Did you try ubersturm's suggestion?
Edit > Preferences > Content > Language. If French is listed above English, select French and click Move Down.
posted by nangar at 12:48 PM on January 27, 2010


I really do think it's an issue with language input.

I use Microsoft's Japanese IME, and language input can switch from application to application. For example, if I'm working on a translation assignment using English input in Word or OpenOffice or whatever, I can switch to Firefox or IE or whatever and type in something in Japanese. In fact, language input can differ if you have two Windows running the same application.

You need to go to Control Panel --> Regional and Language Options --> Text services and input languages --> Settings tab --> Select Default Language Input

Choose whichever version of English you use.

As well, you can also display something called the "Language Bar", which allows you to easily select different input methods.
posted by KokuRyu at 12:56 PM on January 27, 2010


To clarify: You talk about "keyboard changes" but then you talk about effects in Firefox. You are saying not that the language switches (all the text visible on the screen is still in English) but that when you start typing, the keyboard layout is French (probably AZERTY?), rather than English?

If that is correct, definitely try KokuRyu's fix. The fix I mentioned is for cases where Firefox is displaying things to you in French (which it frequently does if you download and install it while the settings are for a different language & input method.)

Alternately: might you have the TabLang plugin installed? This would result in Firefox-specific locale switching.
posted by ubersturm at 1:31 PM on January 27, 2010


I do not have French as a language option in Firefox, nor do I have en-ca, which sometimes has weird keyboard things going on. Default language input in Control Panel is English, with a US keyboard, not a multilingual one. I am not accidentally switching default languages via keyboard shortcut.
posted by jeather at 1:32 PM on January 27, 2010


Sorry, uberstrom, yes: the problem is when I type occasionally my keyboard believes it is (Quebec) French and so the question mark, @, quotes, etc are not where I expect them to be. (It is a QWERTY with different use of the other keys, a standard Quebec French keyboard.) Firefox displays websites in the appropriate language, and the menu settings are the appropriate language. The odd thing is that in other applications, when I type my keyboard always remembers that I want to be using an English keyboard. Firefox sometimes does and sometimes does not.

KokuRyu's fix is something I already did. I need to have an option for a French keyboard in Windows, but I think I will try uninstalling it and then reinstalling it the next day.
posted by jeather at 1:38 PM on January 27, 2010


Reinstalling Firefox would probably not help you in any case, since you're already using the English version. What will probably fix the issue is creating a clean Firefox profile, then making sure the correct input language is active the first time you use it.
posted by flabdablet at 3:11 PM on January 27, 2010


Have you tried just closing and reopening Firefox?

If you set the Windows language settings, it won't affect programs that are running until you restart them.
posted by Sys Rq at 3:32 PM on January 27, 2010


« Older Houston Endometriosis support groups?   |   Help me learn to think of better names for things Newer »
This thread is closed to new comments.