Windows 7 power management insomnia mania!
January 22, 2010 4:23 PM   Subscribe

My windows 7 PC ignores power management options, regardless of the selected power plan.

At some point in the past I had my desktop set to sleep, then hibernate. Later I decided I'd rather just have it sleep. I CANNOT get it to stop hibernating / going into hybrid sleep. It ignores the settings of whatever power plan is currently selected. If I disable hibernation and/or hybrid sleep with an elevated command prompt it goes straight from sleep to hard shutdown, greeting me with a "windows has recovered blah blah blah" upon next boot. 'Resetting' the power management plans has not helped either.

BIOS is set to use S3 power management. The mobo is a Gigabyte 965P-DS3 using the intel 965 chipset.

Any ideas as to how I can remedy this? I'm open to really any options at this point.
posted by datacenter refugee to Technology (7 answers total) 1 user marked this as a favorite
 
Which version of Windows 7 are you running?
posted by Chocolate Pickle at 4:36 PM on January 22, 2010


Professional, non-domained.
posted by datacenter refugee at 5:35 PM on January 22, 2010


You have to be logged in as administrator to change the power management settings.
posted by Chocolate Pickle at 6:32 PM on January 22, 2010


Mine was ignoring power settings for a while, but in a different way. In my case, it kept shutting the screen off after 5 minutes, regardless of what I wanted it to do. I eventually figured out it had something to do with the graphics card driver (I have an nVidia GeForce), and I uninstalled and reinstalled an updated version.

Don't know if that will help, since it's a slightly different issue, but I figured I'd let you know anyway.
posted by lesli212 at 7:12 PM on January 22, 2010


Anecdotally, my Win7 laptop behaves considerably more flakily with respect to sleep and hibernation in response to low battery, lid-shut and the like than it did when WinXP SP3 was installed. It tends to have the most trouble respecting Control Panel settings if you do something like shut the lid, open it, then shut it again without giving the OS time to "think." Several times I've found that the laptop has decided against sleeping and has instead elected to heat itself up and (eventually) start beeping angrily inside my laptop bag.

This is probably the only area in which I've found Win7 performance to be inferior to that of WinXP.
posted by killdevil at 7:40 PM on January 22, 2010


I would check and see if there are any newer BIOS revisions than the one that shipped with your motherboard. I've fought time after time with brand new hardware and quirky power management bugs that are magically fixed by an update.
posted by tmt at 8:04 PM on January 22, 2010


Well the three built-in power plans are still foobar, but I found that if I create a new power plan from scratch it works as expected. Thanks for the suggestions!
posted by datacenter refugee at 5:02 PM on January 23, 2010


« Older How should we manage communication and documents...   |   How to help a long-distance friend with trigeminal... Newer »
This thread is closed to new comments.