Removing Yahoo search results from Firefox address bar search.
January 20, 2010 8:27 PM   Subscribe

When I search for something by typing keywords into the Firefox address bar, it directs me to Yahoo search results. It used to function more like Google's "I'm feeling lucky" option, and I'd like to get that functionality back instead of these incessant Yahoo search results.

To be clear, I am talking about the address bar that typically contains the URL for the current website, and not the search toolbar on the right. I am using the current version of Firefox 3, and am using a Mac, if that matters.
posted by clearly to Computers & Internet (9 answers total) 2 users marked this as a favorite
Didn't FF make some noise recently about Google (which they get a lot of money from because of the FF-Google click-through love, so who knows) pissing them off with their privacy bullshit?

Anyway, try this hint to change the search bar search behaviour.
posted by clvrmnky at 8:31 PM on January 20, 2010

Can you click just to the left of the search box and choose the search engine you want?
posted by a womble is an active kind of sloth at 9:05 PM on January 20, 2010

1. type "about:config" into the address bar (without the quotes) and hit enter.
2. type "keyword" in the find field
3. double click keyword.URL
4. replace that URL with this:

That will make it give you Google results.

If you put in this:

then you get the "I'm Feeling Lucky" behavior.

More info:
posted by intermod at 9:19 PM on January 20, 2010 [2 favorites]

Another possibility is that your ISP has recently changed its DNS servers to redirect to Yahoo! search on DNS lookup failure, probably because Yahoo! is offering them a kickback. If intermod's suggestion doesn't solve the problem, try changing your computer's DNS to Google's.
posted by kindall at 9:59 PM on January 20, 2010

It gave me a regular google search result. Maybe there is something going on with your ISPs DNS servers. I had something like that come up with my ISP and I had to manually disable it. SO annoying.

What's actually in your keyword.URL bar?

The Chrome browser does this automagically.

Not if there's DNS hijacking going on.
posted by delmoi at 10:28 PM on January 20, 2010

My ISP recently started doing this "to be helpful" and I've complained to them about it several times in live chat. Even when you "turn it off" it still doesn't restore normal functionality. It is INFURIATING.

For example, on an uncrippled Firefox browser you are able to type "wiki whatever" into the address bar and it will take you to the wikipedia page for "whatever". I can no longer do that.
posted by carlh at 6:59 AM on January 21, 2010

seconding kindall. at home I can type a keyword in my address bar and go to the first site that has it in the URL, but away from home, on different ISPs, I get Yahoo! results.
posted by toodleydoodley at 8:39 AM on January 21, 2010

CARLH - It sounds like your problem is exactly the same one I had with Comcast. I had to reboot the router and the cable modem to finally get it to take my "Turn it off". Had to completely unplug both of them. Finally fixed it and no problems since.
posted by Noon Under the Trees at 1:03 PM on January 21, 2010

Just a followup, I tried kindall's suggestions to switch mine to google's DNS and it appears to have worked!
posted by carlh at 6:36 AM on January 22, 2010

« Older Avoiding pate de crap   |   Korg D888 No Longer Overdubs Newer »
This thread is closed to new comments.