Disabling "touch-to-click" on my laptop only works for a few minutes.
December 30, 2009 11:28 AM   Subscribe

Disabling "touch-to-click" on my Dell Latitude D630 laptop only works for a few minutes.

I've been using a Dell Latitude D630 running Windows XP for somewhere between 1 and 2 years now. I'm clumsy with the touchpad, so I'd disabled "touch-to-click" from the "Dell Touchpad" control panel. This worked fine for ages. Sometime in the past couple of months, I noticed that I was accidentally clicking on things again. I checked the control panel settings, and the "touch-to-click" box was still disabled, but I could definitely touch to click. If I recheck the touch-to-click box, apply the settings, reuncheck the box, and then apply the settings again, then I can no longer touch to click (which is what I want). Sadly, after somewhere between 1 and 5 minutes (I haven't timed it), it reverts to the previous undesired behavior.

Searching Google, I found one other person complaining about the same problem on the same laptop (2 years ago!), but nobody ever responded to their problem.

Anyone have any idea what's going on here, how to fix it, or how to work around it?
posted by ErWenn to Computers & Internet (5 answers total)
Best answer: The Dell Lattitiude d630 comes with a separate Alps touchpad driver on the driver disks. You might want to look for that in your "Add/Remove Programs" or under the mouse settings in the Control Panel to see if it is installed and conflicting. If you don't see any sign of it, you could try installing it to see if you can get it to control the touchpad.

Personally, I wipe all of our Dell d630s and and don't install the Dell software. If you think you can live without it, try uninstalling it and installing the Alps drivers instead.
posted by cimbrog at 12:48 PM on December 30, 2009

Maybe use this?
posted by deezil at 1:01 PM on December 30, 2009

Response by poster: Thanks for the suggestion, Cimbrog. I'll check it out in a minute.

Excellent app, Deezil. Sadly, my problem is usually while moving the pointer, not while typing.
posted by ErWenn at 1:32 PM on December 30, 2009

Response by poster: Or rather, I'll check it out when I get home in a few days and if I can find the disk. Currently, I do not have the Alps drivers installed.
posted by ErWenn at 1:53 PM on December 30, 2009

Response by poster: Ok, I was going to take Cimbrog's suggestion, but I couldn't find my driver disks and then the problem fixed itself, so there's not much need right now.

Thanks to everyone for their help!
posted by ErWenn at 10:40 AM on January 24, 2010

« Older Yurt? Sensory Deprivation Tank? Abandoned Mental...   |   recommendationfilter/ask.metafilter.com Newer »
This thread is closed to new comments.