Kubuntu Help Needed - Update from 9.04 to 9.1 -> display FUBARed, touchpad borked
December 13, 2009 3:57 PM   Subscribe

This post relates to a Toshiba Satellite Laptop, dual booting WinXP and Kubuntu, where a full package update to Kubuntu ver. 9 has caused some display problems rendering the linux desktop essentially unusable.

I recently updated from a fully operational Kubuntu 9.04 desktop environment to 9.10 via a complete package update. Here are my current boot options.

Kubuntu is now is a mess. If I boot the 2.6.31-15 partition, the active window display has been resized to enormous proportions; for example, here is the KDE wallet login; this is what mouseover text looks like; and this is the right click dialog.

If I click on an active window, I get this, so I'm really at a loss to figure out how to even begin approaching a fix.

If I boot the 2.6.28-11 partition, in addition to the other problems, the touchpad no longer responds, so any proposed fix there must be keyboard based.

Windows still boots up fine and works as good as it ever does.

Can I roll back to 9.04?
If not, I'm looking to fix the display and revitalize the touchpad.
I know I can nuke the HD and start over, but that is not an optimal resolution.
Any help solving these problems is greatly appreciated.
posted by minimii to Computers & Internet (10 answers total)
 
I've fixed similar issues with Ubuntu installs after lots of googling and editing the xorg.conf file, but I'm not sure if this is still the answer with the latest Kubuntu.
Just a shot in the dark but you could try 'sudo dpkg-reconfigure xserver-xorg' from the recovery mode to try to configure the xserver options that control input devices and screen output.
If it helps, you could probably plug in a USB mouse for the short term.
posted by tresbizzare at 4:44 PM on December 13, 2009


I've got Kubuntu 9.10 on a Toshiba Satellite ... installed over a month ago without any problems. Maybe you need to try doing a clean install rather than an upgrade? I know that's not the optimal resolution, like you said, but that is usually the most reliable way to switch to the latest version.

But before that, try tresbizzare's suggestion of sudo dpkg-reconfigure xserver-xorg. I've used that to solve some pretty wacky linux problems in the past.
posted by mannequito at 5:08 PM on December 13, 2009


Those Grub options aren't giving you different partitions. They're letting you run different kernels, but everything else you end up using is the same. There will be some kind of wrongness in /etc/X11/xorg.conf that affects X regardless of which kernel is underneath.

Try booting a 9.10 live CD and make sure it works properly without fiddling. If it does, then you probably just want whatever default xorg.conf comes with 9.10. You should be able to get that by booting into recovery mode, then issuing the following two commands in the recovery mode root shell:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.broken
dpkg-reconfigure -phigh xserver-xorg

If you're not accustomed to dealing with command shells, note that all spaces, slashes, dots and letter cases matter. Enter those commands exactly as they are above.

To get out of the recovery mode root shell, press Ctrl-D, then select Resume Normal Boot from the resulting menu.

Let us know how you go.
posted by flabdablet at 5:10 PM on December 13, 2009


Response by poster: Well, thanks for the tips; but no luck.

The live cd of 9.10 has the same problems.

Can't do the sudo dpkg because the terminal just gives the hash pictured above.

Time to boot & nuke, I guess.
posted by minimii at 8:49 AM on December 14, 2009


Given that the live CD has the same problems, we're probably looking at a piece of autodetection that's gone wrong, and the fix will be manually inserting stuff in xorg.conf. dpkg-reconfigure isn't going to help, because its purpose is to put things back the way they are for the lice CD.

The need to mess with xorg.conf is one of those things that gives Linux a reputation for being fiddly and difficult. That's why Linux distributions have been steadily moving toward requiring fewer and fewer items to be fully specified inside xorg.conf with every release, relying instead on auto-detection. But, as you've just found out, sometimes the auto-detection stuff can get badly misled.

I suspect that what's happening to you is that for some reason X is getting your display size wrong. The display's EDID details include a size in centimetres; X works with a size in millimetres, in order to calculate a display resolution in dots per inch (yes, this is ludicrous). I have occasionally seen X interpret the raw EDID number as millimetres, which makes its dots-per-inch number ten times too big, so fonts and boxes and whatnot end up gigantic. Unfortunately I haven't seen this often enough to know what prompts it.

The workaround is to specify the display size explicitly inside xorg.conf, and tell the driver to ignore the size from EDID. The exact procedure for doing the second part of that is driver-dependent. Do you know what kind of graphics controller is in your Satellite?
posted by flabdablet at 3:43 PM on December 14, 2009


Ctrl+Alt+F1 (or F2-F6) when you're stuck in a messed up graphical state should get you to a console login prompt. That should at least let you try some command line solutions.
posted by Pryde at 11:10 PM on December 14, 2009


Response by poster: Flabdablet, it's got a Mobile Intel 945 GM Express chipset.
posted by minimii at 6:09 AM on December 15, 2009


OK.

I've been researching this a bit, and it looks like the modern way to deal with this kind of issue involves fiddling not with xorg.conf, but with xrandr commands.

How much of this troubleshooting guide makes sense to you?
posted by flabdablet at 6:51 PM on December 15, 2009


Response by poster: First, let me say thanks for the time and effort. I'm trying a few of the suggestions in the wiki. Interesting that Intel graphics appear at the root (pardon the phrase) of the problem.
posted by minimii at 7:25 AM on December 16, 2009


Have a look at the xrandr man page, specifically the --dpi option.
posted by flabdablet at 1:27 PM on December 16, 2009


« Older Should I date other people while involved in a...   |   Help me mediate this age old rivalry Newer »
This thread is closed to new comments.