How to Install Newest Version of Wordpress?
December 12, 2009 7:39 AM   Subscribe

I'm having a horrible time trying to update to WordPress 2.8.6 on my dotster domain. Perhaps you could help a PHP-illiterate sista out?

Background details:

I currently have Wordpress 2.8.4-3, installed via dotster's easy-as-pie Wordpress installer. This is the latest update that said installer offers.

When I try to install the new version automatically via my Wordpress Control Panel, I get a screen that asks me for:

After a lengthy google-fu session, I found out that my hostname is ( and my username is (f197443.admin)
but whenever I enter my info, I get the following error message:

Warning: ftp_rawlist(): open_basedir restriction in effect. File(/tmp) is not within the allowed path(s): (/usr/local/pem/vhosts/197443/webspace/siteapps:/usr/local/pem/vhosts/197443/tmp) in /usr/local/pem/vhosts/197443/webspace/siteapps/15742/htdocs/wp-admin/includes/class-wp-filesystem-ftpext.php on line 203 Warning: ftp_rawlist(): Unable to create temporary file. Check permissions in temporary files directory. in /usr/local/pem/vhosts/197443/webspace/siteapps/15742/htdocs/wp-admin/includes/class-wp-filesystem-ftpext.php on line 203

Unable to locate WordPress directory.

Installation Failed

I have no idea what this means. I don't even know how to access my temporary files directory.

posted by chara to Computers & Internet (8 answers total) 1 user marked this as a favorite
Your account doesn't have the necessary permissions. Eventually, the Dotster easy installer (is it Fantastico?) will have the new update.
posted by sinfony at 7:42 AM on December 12, 2009

Are you able to install new templates and plug ins from the dashboard?
I don't know about Dotster, but with DreamHost you have a choice between a simple install - with no ability to update or modify the program - and a more advanced option that lets you do more.

Check your control panel. Is there a one-click way to upgrade from that?
posted by caveat at 7:45 AM on December 12, 2009

Oh bummer.

So what can I do in the meantime? Right now, the plug-ins feature on my site are broken. It's a personal music blog and I was using WPaudio as an embedded player.
posted by chara at 7:47 AM on December 12, 2009

Caveat, there is a one-click upgrade, but it's only for version 2.8.4-3, not the newest one.
posted by chara at 7:48 AM on December 12, 2009

Do you have any access at all to FTP? (I don't know how Dotster works) The upgrade process for WordPress is incredibly easy. If not, you may be out of luck. If you don't have the right permissions, you're basically stuck.

It might be good to e-mail Dotster support. Maybe if you bring it to their attention they'll release the upgrade faster.

In the meantime, you could switch to a Tumblr and post the music there. They have an option for embedded music - all you have to do is upload the mp3.
posted by caveat at 8:46 AM on December 12, 2009

Best to ring/email Dotster support and ask them for your ftp username and password (explain that it's for upgrade via the Wordpress dashboard) - then when you have those be sure to choose the first "Connection type" option, FTP (not the SSL one). I don't use Dotster but do upgrade WP via the dashboard for various family members, feel free to memail me if I can help!
posted by ceri richard at 8:57 AM on December 12, 2009

Also, you probably already have the ftp login details, do you still have the "welcome to Dotster" email from when you signed up?
posted by ceri richard at 8:58 AM on December 12, 2009

It looks like Wordpress isn't able to access a temp folder, which it needs to be able to unpack the files to. This is pretty easily sorted. I'm making some assumptions about your hosting, so you might need to alter this slightly.

1] In /usr/local/pem/vhosts/197443/webspace/siteapps/15742/htdocs/ add another new folder called tmp. You should now have /usr/local/pem/vhosts/197443/webspace/siteapps/15742/htdocs/tmp/ In /htdocs/, there should also be wp-admin, wp-includes, etc. If they aren't there, find them and put the new folder there.

2] Set the permissions on that folder to 777.

3] In your wp-config.php file at the root of your site, add


right at the bottom, on it's own line. Then try the upgrade again.
posted by Solomon at 9:54 AM on December 12, 2009

« Older Hates job but does it damn well anyway.   |   Do I have a little furry Pavarotti? Newer »
This thread is closed to new comments.