Sending mail...psyche!
November 29, 2009 2:09 PM   Subscribe

Why won't my iPod Touch send mail?

Everything about my new iPod Touch (2G, 32GB) works great - except replying to or sending e-mail. At first it was sporadic, and then after I did the 3.1 software update it stopped altogether.

Receiving mail is perfect. Replying, forwarding and composing email always seems to go fine, it says "sending", there's a little progress bar to show that it's leaving...and then it just never arrives, and never appears in "Sent Mail", presumably because it wasn't really sent.

I suspect it has something to do with the Outgoing Mail Server, which is the Yahoo! SMTP Server, but beyond that I don't have a clue what to do.

One other possibly relevant detail: I also use Microsoft Exchange to sync my Google Calendar with the Touch's Calendar app, and I have a gmail account under "Mail, Contacts, Calendars" to make that happen. Could that cause a conflict?

What do you think?
posted by Bobby Bittman to Computers & Internet (7 answers total)
My mail was completely fubar'd until the first time I completely powered off the device. Just throwing that out there.
posted by gensubuser at 2:15 PM on November 29, 2009

Try changing your outbound port from 25 to 587, if it isn't set like that already. The majority of residential Internet providers block outbound 25 to any servers except their own (for spam prevention services), and 587 is the standard "this server only accepts mail from known senders with valid usernames and passwords for delivery to other recipients" port.
posted by fireoyster at 2:30 PM on November 29, 2009

Hmm, after trying it on my iPhone, I see that the device auto fills the supposed settings for the Yahoo! SMTP Server entry if you set it up by tapping the Yahoo! icon. Assuming you are using a free Yahoo! mail account, I don't believe these settings are able to be changed, since Yahoo! and Apple have some deal going where iPhone/iPod Touch users are able to use accounts on their devices without paying for Yahoo! Plus. Does sending always fail, even if you are on a different wireless network?

In addition, having a Microsoft Exchange account set doesn't interfere. I have one set up as well for "Mail, Contacts, Calendars" and I was able to send via my Yahoo! account.
posted by fireoyster at 2:41 PM on November 29, 2009

Yeah, fireoyster, that info is greyed out, can't change it.

Sending fails 90% of the time. Oddly enough, after posting this I did a few test sends, and they worked, but a couple others a few minutes later failed. That's on my home network.

Good to know that Microsoft Exchange isn't the reason though, thanks.
posted by Bobby Bittman at 2:47 PM on November 29, 2009

Oh you need to go into settings and untick "Use Shortcut" or the "pressing shift key 5 times to turn on" will switch it all back on again.
posted by Admira at 4:21 PM on November 29, 2009

I never could get my mail to go out on my Touch until I went to my e-mail program's "Sent" folder and refreshed it. Items queued in the outbox were finally sent when I did that. No problems since. I use both Yahoo and Gmail and this is the Touch workaround I found useful for Yahoo.
posted by cheapskatebay at 5:52 AM on November 30, 2009

Unfortunately they don't even show up in my Sent folder, so that solution won't work for me. Thanks though.
posted by Bobby Bittman at 11:23 AM on November 30, 2009

« Older carbs or protein   |   1980's TV show Newer »
This thread is closed to new comments.