You've Got Too Much Mail
November 15, 2009 9:43 PM   Subscribe

I am helping a friend who just got a mac set up their computer. They use gmail and I wanted to set up his macmail to get his emails from his gmail account, but when i had the mail account "auto set-up" it began grabbing ALL his emails from his gmail account, and he has more than 10,000 and a great many with large attachments.

We quit program, and now when we restart, it still tries to get all of these emails. So my question is: How do we stop this? If it grabs a 100 or so of the newest emails, that would be fine, but mac mail is trying to grab everything, starting from 2006, and that is unacceptable to my friend.

A second question, is: how do we guarantee macmail doesn't try to delete his gmail emails after grabbing them?
posted by bonsai forest to Computers & Internet (7 answers total) 1 user marked this as a favorite
 
in the Mac Mail app, try going to the Mail menu and selecting Preferences.

Then hit the Accounts tab, select your friend's gmail account on the left, hit the Advanced button, and under "keep copies of messages for offline viewing", select the "all messages, but omit their attachments" option from the drop-down menu.
posted by lalex at 9:55 PM on November 15, 2009


Or, for that matter, "Only messages I've read".

Under "Mailbox behaviors" you can un-check "Move deleted messages to the Trash mailbox" to make Mail.app use the IMAP-standard technique of simply marking the messages as deleted. They won't be actually deleted unless you do "Mailbox > Erase Deleted Items".
posted by hattifattener at 10:11 PM on November 15, 2009


Also what hattifattener said...I'm not sure what the default "auto-setup" settings are, but you might try doing a manual setup. There are many options that you can play with under Mail>Preferences>Accounts>[your friend's gmail address]
posted by lalex at 10:18 PM on November 15, 2009


Has your friend tried "archiving" his gmail? I think that when you have done that, those messages will no longer be in your inbox, and the archived stuff will not be picked up.
posted by i_am_joe's_spleen at 10:59 PM on November 15, 2009


You'll need to go into gmail and change the checkbox under the pop settings to only download messages after today's date. It must be set to try and download all mail at the moment.
posted by slightlybewildered at 11:28 PM on November 15, 2009


You don't say whether you are using GMail's POP or IMAP servers. This is rather important, as behavior in each is quite different. While accessing GMail in the way you describe can be done through POP, it is much closer to the standard method of operation with IMAP, which I would highly recommend you use. Either way, log into GMail and find the following settings under the Forwarding and POP/IMAP tab:

1. Status
[_]Enable POP for all mail (even mail that's already been downloaded)
[x]Enable POP for mail that arrives from now on
[_]Disable POP

2. When messages are accessed with POP, [archive GMail's copy].

If using IMAP, just make sure it is enabled and you should be ok with the defaults. GMail also posts recommended settings for various clients.
posted by sophist at 6:48 AM on November 16, 2009


Thanks so much for answers so far - won't be able to implement your suggestions for several days, but I will be back to report what worked.
posted by bonsai forest at 10:51 AM on November 16, 2009


« Older "Stuck in (Red) Shift"   |   Help teach a woman how to attract the men she's... Newer »
This thread is closed to new comments.