Why does my Asus occasionally behave as if it has no goddam sense?
November 14, 2009 7:11 PM   Subscribe

What is this weird, monospace thing my Asus EEE netbook does for no apparent reason?

Sometimes when I’m typing on my Asus EEE PC, the fonts suddenly all get replaced with this weird monospace thing. Very ugly on the eyes, and Office documents appear to preserve it.

I’m guessing some weird accidental keystroke touches it off, but what the hell? And what can undo it?
posted by jbickers to Computers & Internet (17 answers total) 13 users marked this as a favorite
 
Yeah, so like, right there - typing the question mark seemed to shut it off for some reason.
posted by jbickers at 7:14 PM on November 14, 2009


It's fullwidth form for inputting Chinese characters, and shift-spacebar should switch it on and off.
posted by bewilderbeast at 7:20 PM on November 14, 2009 [1 favorite]


That is very weird. It looks like it doing some strange unicode thing, since there shouldn't be any way to change the font in meta filter pages. The font is even monospaced like that when you view the HTML source in firefox.
posted by delmoi at 7:20 PM on November 14, 2009


Try:

http://forum.eeeuser.com/viewtopic.php?id=29861
posted by the_ancient_mariner at 7:21 PM on November 14, 2009 [1 favorite]


That is not a font or spacing, but rather a specific set of unicode characters. iand i are actually two different characters, for example.

This issue most likely has more to do with your OS than your hardware. Are you using Xandros or XP or something else? Regardless, look into your OS internationalization settings.
posted by idiopath at 7:22 PM on November 14, 2009 [1 favorite]


My ASUS laptop did this until I nuked all but the English language pack.
posted by Inspector.Gadget at 7:33 PM on November 14, 2009


My ASUS laptop did this until I nuked all but the English language pack.

Any advice on how to do this? I'm gathering that it's shift-space that is the culprit, but it would be nice to not have to worry about this anymore ... (and I'm a Windows guy, not well-versed in Linux)
posted by jbickers at 7:39 PM on November 14, 2009


change the settings on SCIM or uninstall it altogether seems to be what people on forums are saying
posted by idiopath at 7:44 PM on November 14, 2009


Check for any packages with "scim" in the name. Those are what provide this functionality for chinese/japanese/korean letter-form sizes. You can probably remove those and it should never be triggerable again.
posted by cmiller at 7:45 PM on November 14, 2009 [1 favorite]


Huh. This question appears completely unreadable on my system (Firefox 3.5.5/Windows XP) - screenshot.
posted by Conrad Cornelius o'Donald o'Dell at 8:05 PM on November 14, 2009


Any advice on how to do this? I'm gathering that it's shift-space that is the culprit, but it would be nice to not have to worry about this anymore ... (and I'm a Windows guy, not well-versed in Linux)

Are you in fact on Windows? I am. If the problem is on Linux then I don't know what to tell you other than looking in your repository with an "installed" filter and looking for anything related to Chinese language.
posted by Inspector.Gadget at 8:08 PM on November 14, 2009


I'm pretty sure Japanese also uses those fullwidth characters, so it may not be language-specific. It looks like under ubuntu the input-method settings are under System > Administration > Language Support; perhaps unchecking something there will help.
posted by hattifattener at 8:21 PM on November 14, 2009


FWIW, I'm running WinXP with Firefox 3.5.5 and the question is legible (though monospaced) for me.
posted by arco at 8:23 PM on November 14, 2009


I think you control that with the "Internet Properties" applet. It should be possible to get to it from the Control Panel, and you certain can by choosing the "options" menu choice in Internet Explorer.

Under the "General" tab there's a "Languages" button. Click it. In the resulting popup, if there are any languages besides English, consider removing them.
posted by Chocolate Pickle at 10:26 PM on November 14, 2009


Thanks all. Just glad it wasn't Zalgo!
posted by jbickers at 7:37 AM on November 15, 2009


Your Asus was designed by Germans (not really).
Germans do indeed use extra spaces for e m p h a s i s. I have seen this on older typewritten envelopes, in academic publishing, and on German IT help sites.
posted by bad grammar at 12:57 PM on November 15, 2009


BG, those characters have a very wide fixed pitch. They're not separated by spaces.

In Japanese they're referred to as "romaji" and they're part of the character set used in Japan which also includes hiragana, katakana, and kanji. If you look at the raw HTML code for this page, you'll find that each of those characters is encoded as a 5-digit decimal number in the range of 65000.

This doesn't have anything at all to do with the German language, or with any European usages.
posted by Chocolate Pickle at 12:46 PM on November 18, 2009


« Older Here comes the rain   |   My apartment is filled with Mace! Newer »
This thread is closed to new comments.