Thunderbird Defaults
January 5, 2005 4:22 PM   Subscribe

Using Firefox with Linux. When I click a "mailto:" link, it automatically opens Evolution. How do I tell it to use Thunderbird instead? I didn't find any obvious settings in either the preferences or about:config.
posted by salmacis to Computers & Internet (9 answers total)
 


What a bloody stupid solution. Why should I have to bugger about with GNOME settings when I don't use that DE? If someone would only make a Qt-fied version of Firefox...
posted by salmacis at 2:07 AM on January 6, 2005


Doesn't Options/General/Use Thunderbird as default mail application work?

Perhaps the other program is automatically making itself the default everytime it opens? Look under its options as well.
posted by sic at 3:59 AM on January 6, 2005


I don't know what version of Firefox you're using, but the options are found under Edit | Preferences, and the General menu has no "Use Thunderbird" section.

Thunderbird is the default mail application in KDE. The problem is that Firefox appears to take GNOME's defaults, even when not using GNOME. I'm back to my old complaint about not being able to configure GNOME apps from within KDE, for which I've still not found a solution.
posted by salmacis at 7:48 AM on January 6, 2005


The problem is that Firefox appears to take GNOME's defaults, even when not using GNOME.

File it with Bugzilla; they're pretty good about fixing things.
posted by AlexReynolds at 9:42 AM on January 6, 2005


salmacis, I was referring to the default mail application checkbox in Thunderbird, but it seems obvious that your problems lie elsewhere. I have to admit that I know very little about Linux (although this summer I plan to switch over) but I found this thread at MozillaZine forums that may be relevant.
posted by sic at 12:05 PM on January 6, 2005


This bug is pointed out in the thread.
posted by sic at 12:07 PM on January 6, 2005


sic, my default mail application is already Thunderbird. That's why I want Firefox to use it! (The thread you mentioned doesn't look relevant, and the bug is obviously not relevant, since it's about when using GNOME.)

More accurately, there is no default mail application checkbox in the linux version of Thunderbird, because in linux, as an OS, the concept doesn't exist. However, both KDE and GNOME support a default mail application. For some reason Firefox appears to be using the GNOME default, even though I'm using KDE, and I have no idea how to change the GNOME default..

There's no point filing a bug at bugzilla. Alex's first link made it clear the developers don't appear to see this as a problem.
posted by salmacis at 2:27 PM on January 6, 2005


There's no point filing a bug at bugzilla. Alex's first link made it clear the developers don't appear to see this as a problem.

That's the wrong attitude to take with developers, trust me. They prioritize fixes partially based on the number of people that report them, among other qualities.

If enough people note the issue, particularly with Linux, developers will address it. A b*g report gets the process started for others to contribute.
posted by AlexReynolds at 2:42 PM on January 6, 2005


« Older Low-end widescreen TV?   |   Why do dog owners stare at their pooping pet? Newer »
This thread is closed to new comments.