Why does my laptop think I'm pushing ctrl?
October 27, 2009 4:50 PM   Subscribe

My Inspiron 1545 thinks I'm pressing ctrl and I don't know why.

I picked up a Dell Inspiron 1545 laptop awhile back, and the only problem I've had with it is that it frequently activates the ctrl key regardless of whether or not I'm actually pressing it- or even have my hands on the keyboard! Sometimes this is just annoying, like randomly crouching in an FPS or tab-targeting grabbing friends instead of enemies in WoW, but if I type a "w" while it thinks I'm pressing ctrl, I lose the Firefox tab I was working in! If I hit tab in Firefox, I frequently go to the next tab instead of the next field. Perhaps most bafflingly, it is only ctrl that this happens with; it never randomly types another character, nor does it ever wrongly activate shift or alt or any other key.

So far, I've talked to Dell about it; they sent me a replacement keyboard, but this did not resolve the problem. Googling indicates that many people are having this problem, but nobody seems to have any solutions (besides one suggestion, bizarrely, to reduce trackpad sensitivity, which did nothing).

Anyone out there know what's going on or have any ideas?
posted by Pope Guilty to Computers & Internet (5 answers total)
 
Totally random and silly idea. This dell, it probably runs a program called kbd.exe @ launch that sets up the "bonus" buttons on the keyboard. You might try disabling it.

Alternatively, you can plug in a usb keyboard which should turn off the keypad on the machine.
posted by TomMelee at 6:04 PM on October 27, 2009


And you probably already saw this thread, because you mention the touchpad, but it's not a sensitivity setting it's the zoom/scroll setting. Pasting:

Its the touchpad causing the issue. Go into the touchpad properties and turn off the zoom in/out feature. Basically the left side of the touchpad is configured like the right side, except instead of scrolling up and down, its set to track zooming in and out. Every time you rest your palm and you get the slightest touch on the touchpad, the keyboard registers CTRL key presses (that is how the zoom feature works).

I had the same exact problem, and this fixed it.


***********************************
and

It's actually a driver problem for the touchpad. I was having the same issue and even when you disabled zooming, touching the middle left side of the touchpad was the equivalent of holding down ctrl. It must have been a driver issue, i.e. that feature wasn't properly disabled. I downloaded the new driver and it works like a charm now. Here's the URL for the new driver from ALPS.....fyi, after you download, install, and restart, you will need to go in and deactivate the zoom/scroll features again....then the control issue should be fixed:

http://support.dell.com/support/downloads/download.aspx?c=us&cs=2684&l=en&s=pub&releaseid=R213504&SystemID=inspiron1545&servicetag=HHH68H1&os=WV64&osl=en&deviceid=16519&devlib=0&typecnt=0&vercnt=2&catid=-1&impid=-1&formatcnt=1&libid=17&fileid=301884
posted by TomMelee at 6:07 PM on October 27, 2009 [1 favorite]


Something else you might want to look into is making sure the Sticky Keys accessibility feature is turned off and that you've disabled its activating hotkey.
posted by flabdablet at 6:35 PM on October 27, 2009


Tom, I somehow completely misunderstood that post and took it to be about sensitivity. I've disabled touchpad zoom (didn't even know touchpads had that feature) and preliminarily, it appears to work splendidly. Thank you so much!
posted by Pope Guilty at 7:07 PM on October 27, 2009


Kickass, sea bass!
posted by TomMelee at 5:26 AM on October 28, 2009


« Older How can we make our low-income year a little...   |   Theft, damage and loss home and contents insurance Newer »
This thread is closed to new comments.