Playlists won't stay random after transfer to iPod
October 25, 2009 2:32 PM   Subscribe

Playlists set to random in iTunes won't stay random on my iPod. How can I fix this?

[searched around and didn't see this exact issue addressed]

I've built a couple playlists (one smart, one regular) for my 5th Gen 30GB Video iPod and set them to random in iTunes. After I sync and disconnect my iPod the playlists are no longer in random order. They are in alphabetical order by album. In Settings, Shuffle is currently set to songs.

This hasn't always been a problem. It just cropped up recently, but I don't normally use a lot of playlists as I mostly listen to podcasts and audiobooks and just shuffle all songs when I want music.

What setting am I missing?
posted by friarjohn to Computers & Internet (8 answers total) 1 user marked this as a favorite
 
Do they play in alphabetical order, or just display that way?
posted by CunningLinguist at 2:50 PM on October 25, 2009


You can switch the play order of all music to "Random" from the settings menu (at least on my somewhat old iPod). You have to switch this off/on if you want to listen to an album in order, but it is not really much of a hassle IMHO.
posted by AtomicBee at 2:58 PM on October 25, 2009


The display did change with the most recent iPod software, at least on my iPhone. I've also been disappointed that the order from iTunes is no longer the order displayed in the list. For me, the shuffling function still seems to work the same way, however, so maybe I'm not talking about the same problem you're seeing.
posted by olecranon at 4:34 PM on October 25, 2009


@CL: They play that way. They only show up randomized in iTunes.

@bee: on the iPod itself or in iTunes? My iPod only has Songs, Albums, off as choices for Shuffle in Settings.

It doesn't have a problem shuffling all songs, just my playlists. And that's only the two new ones. I have an old playlist for poker night and it's randomized.
posted by friarjohn at 4:41 PM on October 25, 2009


If I understand correctly, choosing "songs" for the shuffle settings will shuffle all songs on your playlist when you select the playlist.

When you sort songs into a particular order in iTunes, you need to right-click and choose "copy to play order." If for some reason the shuffle setting on the iPod doesn't work, you could shuffle the list in iTunes and then make that the play order as I described.
posted by AtomicBee at 5:43 PM on October 25, 2009 [2 favorites]


I've been having similar issues to what friarjohn mentions and I wonder if it's a bug in a recent release. I set the playlist (smart) to shuffle songs and it doesn't. Sometimes it will play only 1-2 songs, then stop. Always in the same order. If you try to jump ahead to the next track it just stops after 2 tracks max. All I want to be able to do is to have a long smart playlist randomly cycle indefinitely. And I could swear earlier releases used to do this just fine.
posted by sagwalla at 1:49 AM on October 26, 2009


Bee figured out my problem. "Copy to play order" worked. Thanks!
posted by friarjohn at 8:21 AM on October 26, 2009


Bless you, AtomicBee! I thought I was losing my mind!
posted by wenestvedt at 11:15 AM on October 26, 2009


« Older Since the CalDMV screwed up my smog check date?   |   Help me listen to lastfm in itunes Newer »
This thread is closed to new comments.