Modify Windows Explorer behaviour in renaming savefiles
January 2, 2005 6:16 AM   Subscribe

Saving a file on Windows XP, I use Explorer to select the folder I wish to save to. When I navigate the directories, clicking on an appropriate folder I occassionally move the cursor over filenames. As I mouseover filenames, Explorer replaces the default name of the file I wish to save with the name of the file I mouseover. Can I modify Explorer to prevent this filename replacement?

For example, if I download "foo.exe" Windows opens an Explorer dialog to select the location of the folder to save "foo.exe." If I mouseover "bar.jpg" while navigating directories, Explorer changes the name of "foo.exe" to "bar.jpg." I wish to save the file as it is originally named or how I wish to name it.

This is an annoyance and I have longed searched for a setting/modification to eliminate this behavior with no luck.
posted by quam to Computers & Internet (7 answers total)
 
It'll only change the name if you click on another file while trying to save. It shouldn't just be changing the name when you move the mouse over it. Unless your mouse throws out a lot of random clicks, of course.
posted by wackybrit at 6:52 AM on January 2, 2005


When first navigating explorer, yes, the filename to save does not change and the original name to save is selected.

Once I click a folder, however, the name is no longer selected (blocked) in the "File name:" to save box and the file name is modified if I mouseover a file (while navigating to another folder).
posted by quam at 7:15 AM on January 2, 2005


Thanks wackybrit. I thought about what you said and checked my Click items as follows" configuration under Folder Options > General setting. I prefer "Single-click to open an item (point to select)" and "Underline icon titles only when I point at them."

If I select "Double-click to open an item (single-click to select)," then my annoyance goes away. :)

Unfortunately, I prefer "Single-click to open an item (point to select)" and "Underline icon titles only when I point at them." And it does not look like I can cross-customize the two options.
posted by quam at 7:32 AM on January 2, 2005


try tweakui. I'm not sure it will do the trick, but this is up it's alley...
posted by daver at 9:36 AM on January 2, 2005


I second TweakUI. Install/open it and check if your "Mouse > Hover > Hover time (ms)" setting is set to 0 or a really low value (default is 400); if so, that could certainly be the cause of the instantaneous mouseover selecting.
posted by milov at 10:31 AM on January 2, 2005


Thanks milov and daver. I set my hover time at 1/ms. So far, 200 seems to solve my problem. If my time to move the mouse to a folder across filenames exceeds 200 ms, I know I'll need to adjust the hover time.

I guess it would help to also increase my cursor movement speed. ;) I hope this information is useful to someone else.
posted by quam at 12:02 PM on January 2, 2005


Aha. Nice to see you worked it out. I didn't even think of that. As soon as Internet Explorer 4 turned on that whole 'single click' idea sometime in 1998, I had to change it back ASAP ;-)
posted by wackybrit at 2:26 PM on January 2, 2005


« Older Bringing Japanese Artist's Work to U.S.: Galleries...   |   Selling photography books online? Newer »
This thread is closed to new comments.