Firefox and DNS
December 13, 2004 2:25 AM   Subscribe

I have managed to install my beloved Firefox on my "heavily secured" computer at work and told it to use the company proxy server (we can only go through port 80). I'm not supposed to be using anything other than IE, but, well, you understand. The problem is that I can't access any .net domains (.com, .org, .co.uk and any other TLD works as it should) with Firefox, while this is not a problem in IE. Using the IP number of a .net website brings me to the site just fine, so it seems to be a DNS issue, but I have never heard of a TLD requiring its own DNS server or a special port. I can't ask the company IT people as I'm not allowed to use FF in the first place, and the FF support forums have never even answered my question. Any ideas?
posted by Skyanth to Computers & Internet (9 answers total)
 
If other addresses are resolving fine then the likelihood of it being a specific DNS issue is unlikely.

I'm assuming that .net addresses work in IE? If so, then the only way I could see this happening is if the proxy server is dissecting your headers, filtering for non-IE browsers, then blocking .net addresses. Running the Internet Explorer Administration Kit (IEAK) allows an administrator to set a unique user agent on IE that allows the proxy server to filter certain browsers.

Blocking .net addresses is strange though.

Try this extension in Firefox. But first, if you want to find the specific user agent, create an .html file with the following:

<html>
<head>
<script language="javascript 1.3" type="text/javascript">
document.write (navigator.userAgent);
</script>
</head>
</html>

(Open it in IE, if it warns you about blocked content, just click the option bar and select allow blocked content).

If that doesn't work, then I have no idea what else to try. A word of caution though, changing the user agent is not always a good idea. A lot of sites adjust content based on the browser and it could affect your browsing experience. However, being stuck with IE definitely affects it already, so the way I see it, you probably have nothing to lose.

IT departments blocking Firefox? That's a whole other issue.
posted by purephase at 5:18 AM on December 13, 2004


I bet FireFox is resolving DNS outside the Proxy server. I don't know how to switch that, but it must be somewhere in the Firefox manual. :)
posted by shepd at 5:49 AM on December 13, 2004


You might want to check the 'Tools > Options > General > Connection Settings > No Proxy For' box...while I am sure you have rooted through these before, it is possible that .net is in there and could be affecting your resolving abilities (this being a rather strange problem).
posted by gren at 6:02 AM on December 13, 2004


Thanks for your help, I just solved it thanks to gren:

Yes, I had already looked through the No Proxy For settings to make sure it didn't contain anything like .net, but I had noticed before that by default (other colleagues who had installed Firefox following my... gentle coaxing had the same thing) that field contained "localho,t" instead of "localhost". I never thought anything of it (thinking it some kind of weird wildcard for some reason) and only now decided to change it. Result: all .net domains suddenly reachable. After months of having to fire up IE just to read boingboing. :)

So, thanks for making me think! This alone was worth the 5$ meta money.
posted by Skyanth at 6:16 AM on December 13, 2004


(I can't believe I thought it was a wildcard. How stupid am I.)
posted by Skyanth at 6:18 AM on December 13, 2004


hm, interesting. was it a nightly build or something? I tend to stay away from those or the alphas because they can be a bit buggy. glad you fixed it though! Feels good to be IE free doesn't it?
posted by freudianslipper at 7:25 AM on December 13, 2004


if you type "about:config" it will give you access to all of the options for Firefox. You might find something in there.
posted by jackofsaxons at 12:53 PM on December 13, 2004


A loosely-related aside - I use the amazing Portable Firefox to get away from IE on my "locked down" (but not the USB ports, dumbasses) work box. No admin privs required to install, no nagging worries about histories, cookies or caches.
posted by obiwanwasabi at 2:40 PM on December 13, 2004


wewt wewt !!! gren++
posted by gren at 5:52 AM on December 14, 2004


« Older Lord of the Rings Questions   |   Why won't my Powerbook G4 battery hold a charge? Newer »
This thread is closed to new comments.