How do I share internet between two iMacs?
July 20, 2009 3:06 PM   Subscribe

How do I share internet between two iMacs? One is new iMac connected to internet wirelessly through internal airport. Ethernet is connecting it to the other (older) iMac. How do I get older iMac online through the first iMac's connection?

We had this working months ago, for some reason not anymore. Tried going into ...

system prefs>sharing

set up incoming as airport, outgoing as ethernet. but second iMac is not seeing the first one.
posted by slowtree to Computers & Internet (12 answers total) 2 users marked this as a favorite
 
are you using a crossover cable between the two macs?

If not, that's very likely to be your problem.
posted by namewithoutwords at 3:31 PM on July 20, 2009


The Mac will adjust for the type of cable automatically, namewithoutwords

If Sharing is definitely set up correctly on the first mac, look to the second Mac's settings.

Is it set up to use Ethernet?

Is that Ethernet configured to use DHCP (it'll have to be to use Connection Sharing)?

Then, can that Mac see the first Mac (try turning on Web sharing in the first Mac and browsing to the address it gives you from the second Mac)?
posted by fightorflight at 3:35 PM on July 20, 2009


Double check that crossover cable. You can also try firewire sharing, preferences>network>firewire
posted by limited slip at 3:36 PM on July 20, 2009


Details on which macs need a crossover cable and which can autoadjust.
posted by fightorflight at 3:41 PM on July 20, 2009


Response by poster: We have the main mac sharing the Internet from its airport connection to the Ethernet cable. The other mac sees the Ethernet connection and is assigned an IP address but has a yellow light when trying to access the Internet. There is no firewall active. Cable is good. Have rebooted both machines
posted by slowtree at 4:44 PM on July 20, 2009


Yellow usually means a self-assigned address -- so it's not getting one from the serving Mac. I'd check the console log for both to see if there's anything helpful.
posted by fightorflight at 5:16 PM on July 20, 2009


What is the ip address? Is it a 169... address? If so, try restarting the non-airport mac, and see if it gets a dhcp ip.
posted by hal_c_on at 1:19 AM on July 21, 2009


connect everything up then type ifconfig into your terminal and post the output.
posted by low affect at 9:53 AM on July 21, 2009


Response by poster: The IP address is 102.168.2.19

When I go to terminal, i type in ipconfig, this is what shows...

Last login: Tue Jul 21 21:51:47 on ttyp1
Welcome to Darwin!
stacey-downeys-computer:~ staceydowney$ ipconfig
usage: ipconfig
where is one of waitall, getifaddr, ifcount, getoption, getpacket, set, setverbose
stacey-downeys-computer:~ staceydowney$

Also when I try to go into Network settings on the non-airport iMac, a window incessantly pops up saying YOUR NETWORK SETTINGS HAVE BEEN CHANGED BY ANOTHER APPLICATION. Everytime I click OK, it pops right back up. I have to go in to force quit to get out of it. Not sure if this is relevant or not.

And lastly, the console log has some things about MenuCracker. Not ever sure what that is.

Maybe we are missing important steps in the set up? Can someone list a step by step for the settings?

The only geek in the house is a PC guy, so sorry if all this seems really ignorant.

posted by slowtree at 7:13 PM on July 21, 2009


it's ifconfig you need to type (ie ifconfig, not ip).

YOUR NETWORK SETTINGS HAVE BEEN CHANGED BY ANOTHER APPLICATION.
Ah, if you're running 10.4, this is your problem. A Security Update has buggered yr networking.

To fix:

1. Open Applications > Utilities > Disk Utility
2. Click the name of your hard disk in the left pane (probably "Macintosh HD").
3. Click the "Repair Disk Permissions" button under the "First Aid" tab
(this is usually mac troubleshooting voodoo, but Security Update 2008-006 can knacker some of NetworkConfig's permissions, so it's actually required here).

Then:

4. Go to System Preferences, and click on Security.
5. Click the "require password to unlock each System Preferences pane".
6. Close it, and open the Network pane. Set it up correctly to connect to the iMac (Ethernet > Configure: Using DHCP). Save and close.

Hopefully this should do it.
posted by fightorflight at 8:44 PM on July 21, 2009


Response by poster: I must be missing am important step here somewhere. I did everything listed above, still no luck.
posted by slowtree at 9:15 PM on July 21, 2009


Hmm. Can you type ifconfig and paste the result? A screenshot of the network pane wld also be useful.
posted by fightorflight at 9:41 PM on July 21, 2009


« Older Guess I can't be on my back so much   |   Lord of the Rings Playing Card Game Newer »
This thread is closed to new comments.