iPhone Has Me Captive!
July 16, 2009 9:59 AM   Subscribe

How to stop iPhone OS 3.0's captive portal page?

This is a dumb thing to waste my question on, but the new functionality of iPhone OS 3.0 has broken my wifi connection at college.

Now whenever I connect to a network with a captive portal, iPhone helpfully opens the page so I can login. This works great, except at university where you get a captive portal telling you to login via VPN.

Unfortunately, if I hit cancel on the iPhone's window so I can go over and turn on the vpn, the iPhone disconnects me from the network. No network connection = no vpn connection.

How can I turn off this new iPhone feature? Or exempt my college's network?

I've looked at all the options I could find and didn't see anything relevant. Hopefully I'm just overlooking something obvious.
posted by icebourg to Technology (6 answers total) 2 users marked this as a favorite
Turn on the VPN first?
posted by Oktober at 10:03 AM on July 16, 2009

If you go to settings and hit the 'Wi-Fi' option, you should get a list of networks. Tap the > in a blue circle next to your college's network, and there should be an option there to turn off the feature (I think it's called Auto-login or something like that). Then you can do your worst with the VPN and it shouldn't auto-open.
posted by jaffacakerhubarb at 10:55 AM on July 16, 2009

I believe you have to be on a network that has successfully been "Auto-Join"ed to get the option in your Wi-Fi Settings, so you might not find the setting jaffacakerhubarb is referencing.

This is not for end users (sorry!), but if you're running a network that suffers from the all-or-nothing nature of the iPhone OS 3.0 hotspot autologin feature, you can route around this by adding a file at http://[your-registration-url]/library/test/success.html

I learned this here:


...and when I did it for our campus network, it worked just fine.
posted by jmcmurry at 12:04 PM on July 16, 2009

Response by poster: I don't think the Vpn will turn on without a coonection unfortunately, but if there's enough of a delay it might work. And I have no control over the network. Any way to just turn the feature off universally? I like it at some places but not if it interferes with my college network.
posted by icebourg at 12:15 PM on July 16, 2009

Best answer: Reports in that linked thread and others indicate that installing the free Boingo app from the app store disables auto-login for all Wi-Fi networks. I use the auto-login so I have not personally tested it, but that seems like a decent option.
posted by j.edwards at 12:34 PM on July 16, 2009

Response by poster: Looks like Boingo is the way to go. Thanks. I knew I could count on Ask MeFi.

And I will send the powers that be a jmcmurry's link.
posted by icebourg at 2:57 PM on July 16, 2009

« Older "eVent" is a terrible name to Google   |   Organizing images and graphs Newer »
This thread is closed to new comments.