How do I override "Override All Compatibility" in Firefox?
June 30, 2009 3:09 PM   Subscribe

Installed Firefox 3.5 today and accidentally hit "Override all Compatibility". Now CPU is at 99%. Any way to UNDO this?

So I have a LOT of extensions, and after installation, Firefox showed a long list of those not yet compatible with 3.5. I was OK with Firefox disabling those add-ons, but then I mistakenly hit "Override all Compatibility" (from Nightly Tester Tool) on my Extensions page. Now (duh) the extensions are not playing nicely. Major memory leaks.

I ran in safe mode, turned off all extensions, and added them back in groups of five, but couldn't pinpoint any problem. Then I came back to my computer and Firefox was running at 99% again. I disabled the last five add-ons; didn't do the trick.

I uninstalled NTT, reinstalled NTT, reset Firefox preferences, reinstalled Firefox... I can't get Firefox to pinpoint my incompatible extensions again. Runs fine with all extensions off, but what kind of life is that?

I don't even remember why I got Nightly Tester Tools in the first place, but I'm waaay out of my depth here. Any ideas?
posted by for_serious to Computers & Internet (5 answers total) 2 users marked this as a favorite
 
An older post, which I think is still comprehensive:


If you've eliminated hardware and other software or viruses as the source of the problem, and Firefox still runs slow, consider:

A. Exporting your bookmarks from the bookmarks organizer.
B. Making a list of extensions you use (vetting them, of course, against the official list of Known Problematic Extensions.
C. Uninstalling Firefox, deleting the "Mozilla Firefox" folder under "Program Files" if it remans, deleting the "Firefox" folder under your Application Data folder (On XP, Documents and Settings\You\Local Settings\Application Data\Mozilla\ OR on Vista \Users\You\AppData\Roaming\Mozilla\), and doing a search with regedit for "Firefox" (or "Mozilla" if you don't use Thunderbird) to delete all related registry entries.
D. Re-installing Firefox, re-installing your extensions, and importing your bookmarks using the bookmarks organizer.

This is the "nuke from orbit" option for Firefox. It deletes and replaces all program components and personal settings. Only do this if you have ruled out other potential causes of the problem. It is more thorough than just deleting your Firefox profile folder because it replaces potentially corrupted program files.
posted by Inspector.Gadget at 7:42 PM on March 7, 2008 [2 favorites +] [!]
posted by Inspector.Gadget at 3:20 PM on June 30, 2009 [2 favorites]


If you can get back into firefox, type about:config into the address bar. Then search for:

extensions.checkCompatibility

...and see if toggling that works.
posted by null terminated at 4:06 PM on June 30, 2009


(I'm not sure whether the checkCompatibility flag is tested when installing extensions or every time they run. Even if that's set correctly, extensions that have already been installed when the flag was set to not check compatibility may continue to run)
posted by null terminated at 4:08 PM on June 30, 2009


I ran in safe mode, turned off all extensions, and added them back in groups of five, but couldn't pinpoint any problem.

Who says the problem has to happen at load up? Maybe its happens when some function is called or when some extension performs some action. If youre a heavy extension user, do what I do, just use the old version of FF until the extensions are caught up. Or run a second install sans extensions if youre dying to play with it.
posted by damn dirty ape at 5:00 PM on June 30, 2009


Well, good news and bad news.

I tried the about:config trick, no luck. Was really hoping there was a simple "undo" button I'd missed! So before going nuclear, I searched Mozilla for every damn extension I had, and only enabled extensions that were specifically OK for 3.5.

HOWEVER this still didn't solve the problem. After several dozen restarts, it looks like Greasemonkey is the troublemaker. It says it's compatible but it seems to max out Firefox within minutes. I may wind up downgrading after all...

Thanks all for the advice!
posted by for_serious at 6:30 PM on June 30, 2009


« Older Help me learn PHP!   |   Help me fancy up my homemade corn tortillas! Newer »
This thread is closed to new comments.