dammit!
June 28, 2009 9:11 PM   Subscribe

Macfilter: why does Mail keep launching itself?

It's not my default mail client (I've got G-mail notifier). It's not one of the applications that's part of my start-up. I've deleted all of my mail accounts from it. It keeps popping up with the d*mn welcome screen. Very irritating, and I can't figure out how to get it to stop.
posted by leotrotsky to Computers & Internet (7 answers total)
 
I can think of a couple of possibilities-
- Is the program trying to update itself? Programs sometimes open automatically to notify you if there's a newer version available.
- Is the a process that is trying to send mail somewhere (maybe automated notifications or something)? If so, it might be trying to open Mail to send a message (do you have it set as your default e-mail program in any application?)
posted by fearthehat at 9:54 PM on June 28, 2009


Do you use ical? I think I was running into this problem occasionally when I used google calendar + ical, because it was launching mail to presumably send me alerts from my calendar? Unfortunately I can't remember what I did to make it stop. Maybe stopped using ical?
posted by backwards guitar at 11:20 PM on June 28, 2009


When does it pop up? Every time you reboot/log on? In that case, check the system preferences, Accounts, login items. It may be check in there to launch on every boot.
posted by DreamerFi at 3:29 AM on June 29, 2009


Response by poster: i just starting syncing ical to gcal, so potentially that's the issue.

It's not a login item.
posted by leotrotsky at 5:08 AM on June 29, 2009


Best answer: Ding ding! We have a winner. Syncing iCal to Google calendar did this to me too. Both apps get set to email you a reminder and iCal seems to only launch Mail. Since I've switched my iPhone to 3.0 and get my Google calendar directly in the calendar app on my phone, I've finally found peace ;)
posted by advicepig at 6:53 AM on June 29, 2009


If you don't use Mail and never want it to launch again, you could make an archive of it (you can just right-click or control-click the file and choose "Create Archive") and only unzip it just before you do any Software Updates.
posted by bcwinters at 4:50 PM on June 29, 2009


Best answer: If you don't need iCal to trigger alarms, try going into the preferences, advanced, and checking 'turn off all alarms'.
posted by cayla at 8:40 PM on June 29, 2009


« Older Teach me your TwitterFu   |   Shirts and Prints that go Squee!! Newer »
This thread is closed to new comments.