Dear Google, Why are you automatically deselecting the top search box?
June 8, 2009 2:19 PM   Subscribe

Google search seems to be exhibiting an irritating new behavior. Please help!

At work, I spend a lot of time doing quick fact-checking on Google. To execute the many searches this requires, I either, per suggestions from this 2007 query,

1. hit Command-L to quickly highlight the address bar's text, then type a Firefox search shortcut, e.g. google cheetos, and hit enter, or

2. if I'm already on a Google search page (e.g. this one), hit tab once to select the text in the top search field (since searching from there seems to require less load time than searching cold from the address bar), then type my query and hit enter. To make searching even quicker next time, I normally tab to this box immediately after completing the previous search, so that when I Command-Tab back to Firefox from the Word doc I'm working on, the text in that field is selected and ready to be replaced.

I don't use the dedicated search box in Firefox (I've removed it from the navigation toolbar), and would prefer to continue not to.

Unfortunately, either Google or Firefox seems to have changed something over the weekend, as I've noticed something odd today when I've attempted to use method No. 2. When I've just completed a search and tab to the first search field on a page like this, all the text in the field is initially selected, but then quickly deselects, leaving the browser's focus still on the field, but the text inside unselected. This means that instead of quickly typing in a query to replace the text in the field, then hitting enter, I have to additionally hit Command-A to select the text in the field before typing my query.

It's just an addition of one keystroke, basically, but it's throwing me off my usual search rhythm. Also, while I know I could just hit tab again to select the text in the bottom search field on the page, I'd prefer to continue searching from the top search field—or at very least to solve the mystery of why the text in that field is automatically deselecting.

Does this make sense? And has anyone else who uses a similar method of searching Google experienced this today? If so, can anyone help me figure out how to get the old selection behavior back? My only guess would be that it has something to do with Google seeing the rapid selection of that box immediately after a search is executed as somehow accidental, and attempting to correct that. But my doing so is very much on purpose!
posted by limeonaire to Computers & Internet (18 answers total)
 
What Firefox extensions, Stylish userstyles, and/or Greasemonkey userscripts do you have installed? Did any of them recently update?
posted by WCityMike at 2:32 PM on June 8, 2009


No Stylish userstyles or Greasemonkey userscripts.

Extensions:

BugMeNot 2.1
ColorZilla 2.0.2
Delicious Bookmarks 2.1.041
Duplicate Tab 1.0.2
Nuke Anything Enhanced 0.68.2
Pearl Crescent Page Saver Basic 2.1
QuickRestart 1.1.5
ReloadEvery 3.0.0
Resurrect Pages 2.0.4
SamePlace 2009042606
TinyUrl Creator 1.0.5
Tweak Network 1.3
User Agent Switcher 0.6.11
XMPP Developer 2009031613
xmpp4moz 2009042411

Have others installed, but not enabled—so those shouldn't be a factor, right?
posted by limeonaire at 2:41 PM on June 8, 2009


The only extension I can recall updating today was TwitterBar, which is and has been disabled.
posted by limeonaire at 2:45 PM on June 8, 2009


This may not help you; I use the firefox search bar, by doing alt-d then tab. It's a quick, fluid movement, highlights previously entered text, and never fails. GL.
posted by gensubuser at 2:58 PM on June 8, 2009


Similar/same issue, and similarly deeply irritating: on Google's search page, type yer search text into the textbox. Then hit the enter key. Google USED to treat that as pressing the search button. Now I get nothing, and have to move the mousepointer over and press the button like a dope. Not fond of that at all.

Using Opera 9.62, no updates or changes. I also noticed the new behavior over the weekend.
posted by oldtimey at 3:02 PM on June 8, 2009 [1 favorite]


This may not help you; I use the firefox search bar, by doing alt-d then tab. It's a quick, fluid movement, highlights previously entered text, and never fails. GL.

Ctrl+K takes you straight there
posted by Luddite at 3:13 PM on June 8, 2009


Ctrl+K takes you straight there

Alas, I know that shortcut, but avoid it for the same reason I don't like to use my option No. 1 above as often—it requires loading a new page in the browser. I'd rather just work straight from the search page I already have loaded up, since my work connection can be really slow.

I use the firefox search bar, by doing alt-d then tab.

Well, thanks for the tip. I may consider it if I can't find a solution that's closer to what I was originally doing!
posted by limeonaire at 3:21 PM on June 8, 2009


Similar/same issue, and similarly deeply irritating: on Google's search page, type yer search text into the textbox. Then hit the enter key. Google USED to treat that as pressing the search button. Now I get nothing, and have to move the mousepointer over and press the button like a dope. Not fond of that at all.

Huh, weird. For the record, I tried it out on Firefox on OS X and didn't experience that problem—hitting Enter initiated the search like usual—but that does sound incredibly irritating. At least from our two data points, it sounds like Google's been tweaking the search box...
posted by limeonaire at 3:27 PM on June 8, 2009


Small piece of info that you may or may not find useful:

About two weeks ago, the javascript on the main Google page got updated and there were a slew of bugs, for some reason which I don't know. For another reason which I don't know, Google hasn't really fixed any of them; none of them are dramatic, but they're enough to cause a little bit of hassle for people (like me) who use the site a fair bit during the day and are stuck on certain ways to move fast within it.

Case in point: focus on the “Google Search” button stopped being default in Opera. That may seem tiny, but it meant that every time I keyed over to do a Google search, I'd type in my search-phrase, press enter, and…nothing would happen. I'd hit enter about four more frustrated times before remembering that “Enter” suddenly isn't working for Google in Opera…and I'd reluctantly reach for the mouse. I finally reset my User Agent to tell Google that I'm using Firefox instead of Opera so that it would let me used the *#&$# enter key again. Apparently, I'm not the only one; and I've seen and heard more stories of little troubles with the javascripting on Google in the last few weeks.
posted by koeselitz at 3:58 PM on June 8, 2009 [2 favorites]


Small piece of info that you may or may not find useful

That is definitely useful—it sounds just like what oldtimey was describing.

And actually, poking around on Google's Web Search Help, it looks like a lot of Firefox users are having the same problem you guys are, too. This thread seems to pinpoint the JavaScript problem as originating with the addition of "Doodle 4 Google."

Hmm. Haven't found a thread yet describing my bug, though.
posted by limeonaire at 6:17 PM on June 8, 2009


This thread suggests you guys' bug is an Ajax thing. Wonder if mine is related?
posted by limeonaire at 6:19 PM on June 8, 2009


I posted this query in the Google forums. I'll let you all know if I hear anything useful back...
posted by limeonaire at 6:27 PM on June 8, 2009


As I noted in that thread, to clarify further, this was happening when I was at work using Firefox 3.0.10 on Mac OS 10.4.11. I'm currently not experiencing the problem at home on OS 10.5.7.
posted by limeonaire at 6:32 PM on June 8, 2009


HOORAY -- this worked for me -- tip is from koeselitz's link. You are my hero.
>>"Turning the query suggestion feature off in Google preferences, everything works fine again.">>

limeonaire is also my hero for posting the question, because I noticed the issue and thought I was just doomed from here on out and I was probably the only person among millions of users who was experiencing a problem. Thank you for helping fix my internet . . . I hope we can fix your bug too . . .
posted by oldtimey at 8:07 PM on June 8, 2009 [2 favorites]


I'm glad that helped, oldtimey. And if you're really attached to the query suggestion thing (I like having the drop-down of suggestions, but a lot of people don't) you can also fix this in Opera by navigating to the Google front page and then doing Tools->Quick Preferences->Edit Site Preferences…->Network->Browser Identification->Identify As Firefox (or Identify As Internet Explorer, etc).
posted by koeselitz at 6:26 AM on June 9, 2009


Hey, glad I could help. Looks like there's been progress made on you guys' issue in this thread, too, where a Google employee actually responded.

Bizarrely enough, I'm no longer experiencing the issue I posted about, whether I'm logged into my Google account or not, on my work computer. Perhaps they made a quick fix; I'd say it was probably just a result of clearing the browser's cache on logout last night, but I did that during the day yesterday, to no effect. I'll let you know if it comes back, though...
posted by limeonaire at 7:47 AM on June 9, 2009


OK, wrote too soon—I decided to test further to make sure it was gone, and no, it's still occurring, provided I hit tab quickly enough after a search has concluded. It seems like it's almost a problem of some page element continuing to load after most of the page is already there; as a result, the selected text in that top search field is deselected as soon as the page has finally loaded completely.
posted by limeonaire at 7:59 AM on June 9, 2009


Okay, limonaire. To focus and expand on my first comment: the fact that it's happening at home on a similar system but not at work points (in my eyes, anyway) to something browser- or system-specific; the most likely culprit is javascript, and the reason that would be a culprit is because of user agents: your browser identifies itself whenever it navigates to a page, telling that page that you're using Firefox or Internet Explorer or Opera or whatever so that that page can send the proper javascript; the mechanism which broadcasts your browser type is called a user agent.

A lot of times, you can get rid of javascript-specific problems by switching your user agent to announce that you're using Internet Explorer or Google Chrome or something else. To do that in Firefox, get the User Agent Switcher extension and set it for something other than what you're using. (Keep in mind that, even if you could use the IE Tab extension—I don't think you can on a Mac—it would be an inconvenient and pointless way to do this; you don't need the whole rendering engine of IE, you just want to switch user agents.)

I would try that. It's a fair shot; it's kinda like kicking the thing. Something might shake loose, and that thing might be what you're hoping for. Give it a go.
posted by koeselitz at 3:27 PM on June 9, 2009


« Older RF remote control   |   ok, who put acid in my coffee? Newer »
This thread is closed to new comments.