Networking Mac and Windows via ethernet
June 7, 2009 8:18 AM   Subscribe

Please help me troubleshoot my (cross-platform) home network. Networking already works via wi-fi, but not via ethernet cable.

I'm networking a Windows XP PC to a Mac Mini running OS X Leopard. I have already succeeded in setting it up so that I can browse the Mini from Windows in "My Network Places" or via a mapped drive letter, but this is slow (802.11g) and I want to transfer large files.

I have bought a 20 meter cat5 cable (crossover) and connected the two computers, and disconnected the wi-fi adapter. Can I expect the network to work straight away without further configuration? Anyway, it doesn't. Please help!

(Irrelevant background: I only need to do this because the Mac Mini's DVD burner is useless -- I keep getting the "failed to calibrate the laser power level" error. So I'm forced to use the PC for burning.)
posted by snarfois to Computers & Internet (10 answers total) 1 user marked this as a favorite
 
Can I expect the network to work straight away without further configuration?

No, although the link integrity light should come on beside each Ethernet port right away. You'll then have to assign an IP address and subnet mask to each port (e.g IP address 192.168.1.100 on one machine, 192.168.1.101 on the other, subnet mask 255.255.255.0 on both). That might be enough to get it working.

Or if your wireless network includes a router that also has wired networking ports, just plug both computers into those (using straight-through cables) and it'll probably take care of all this for you with DHCP just as it would for a wireless network. You'll get Internet access and DNS service included in the deal this way too.
posted by FishBike at 9:01 AM on June 7, 2009 [1 favorite]


FishBike is right. There is a small possibility they will fallback autoconfigure. This will show up as 169.254.X.X IP addresses but it's easier to just to build your own subnet like FishBike says.
posted by chairface at 9:05 AM on June 7, 2009


Others are probably more qualified to address the networking issue, but as for the DVD burning issue, I would try these steps (listed in order of hassle factor):

1. If you've never successfully burned a DVD on the mini, and you've never played a DVD on it either, try playing a DVD on it. This may set (or re-set) the region code.

2. Try setting the burner to burn at the slowest setting (usually 2x). If the media you're using is not the greatest, this might help.

3. Try a different brand of blank DVD. It's amazing how finicky about cheap media these burners can be. Verbatim, Taiyo Yuden, and Ritek are frequently cited as being among the most reliable; I've never had a problem with Verbatim burning in a Mac.

4. For an excellent discussion of your particular error and Mac burning issues in general, see this thread: http://forums.macosxhints.com/showthread.php?t=77414
posted by dinger at 9:37 AM on June 7, 2009


Seconding Fishbike.

And note that afte you do that you may find that the wireless stops working. In that case, set the wired Ethernet interface on both computers back to "automatically configure network" or whatever they call DHCP in their respective environments.
posted by intermod at 9:54 AM on June 7, 2009


Can I push my luck here and ask how I "assign an IP address and subnet mask to each port"? Does "each port" refer to the port on the PC and Mac respectively? Is this a job that needs to be done on each computer separately?

My wireless router does have network ports, but it's on a different floor of the house so I'd need 2x20m straight-through cables (and I'd have wasted my money on the 20m crossover cable.) So I don't think this is an option for me.

dinger: I've tried 3 different brands of blank DVD so far, without only occasional success. (Completely unreliable.) I've tried using 2x speed; no better. DVD playing works fine without problems.

Thanks for the help so far.
posted by snarfois at 10:13 AM on June 7, 2009


Can I push my luck here and ask how I "assign an IP address and subnet mask to each port"? Does "each port" refer to the port on the PC and Mac respectively? Is this a job that needs to be done on each computer separately?

Yes, yes, and yes.

I don't know which version of Windows you have, and for some reason this is one of those things that Microsoft keeps changing. Here's approximately how to do it in Windows XP:

1. Go into the Control Panel
2. Find the "Network Connections" control panel and open that (if you're in classic view it's one of the icons, if you're in category view it's under Network and Internet Connections category)
3. You should see an icon called something like "Local Area Connection" that represents your wired connection. Right-click that and select "Properties"
4. In the "This connection uses the following items" list, find "Internet Protocol (TCP/IP)" and highlight it
5. Click on the Properties button
6. Now you'll see something that says "Obtain IP Address Automatically" and that is selected. Click on the "Use the following IP address" option below that.
7. For IP Address, enter: 192.168.1.100
8. For Subnet mask, enter: 255.255.255.0
9. Leave the default gateway blank
10. Click OK and you're done on the PC

I'm guessing the process is similar on a Mac, but I don't know enough to tell you the details. You will want to do the same thing, but use the IP address 192.168.1.101 there (the last number has to be different from the address on the PC). This kind of thing is called a static IP address if you want to Google for OS X instructions.

To put everything back as it was, just go through this again but put it back on the "Obtain IP Address Automatically" option.
posted by FishBike at 11:05 AM on June 7, 2009


For the Mac instructions:
1. Go to the apple icon in the upper right and choose System Preferences...
2. Choose "Network" under "Internet and Network"
3. In the menu on the left choose "Ethernet"
4. Click the drop-down that says "Configure" and choose "Manually"
5. To match FishBike's instrcuctions, choose "192.168.1.101" for IP Address, and 255.255.255.0 for subnet mask. Leave the rest blank.
6. Click "Apply" in the lower right.

When the cable is plugged in the "Ethernet" option in step 3 should have a green dot next to it and it should say "connected" underneath.

To revert (in order to plug the Mac in to a router, for example), follow step 1-3, but for step 4 choose "Using DHCP" and click "Apply".
posted by five toed sloth at 11:20 AM on June 7, 2009 [1 favorite]


I wouldn't use 192.168.1.100 because this is the first IP handed out by DHCP on most home routers and may conflict. You can choose anything in 192.168.x.y, just make sure x is the same on both machines.

Make sure the link light is on for both machines. I don't think a crossover is strictly necessary these days.
posted by cj_ at 12:15 PM on June 7, 2009


FishBike, you're a star. Thanks ever so much for your help. I figured out the rest myself and was going to post it here, but thanks, five toed sloth, for doing the job for me and completing the thread as a nice self-contained solution.

cj_, I'll bear that in mind, although in this instance I had no problems.

Incidentally, I kept wi-fi disabled on the PC in order to not interfere somehow, although I don't know if this is strictly necessary. The Mac happily stayed connected to the internet via airport.

I'd previously networked 2 Macs together using a crossover cable without needing to do any configuration, hence why I originally expected this to work straight away. Anyway, now I know.
posted by snarfois at 12:41 PM on June 7, 2009


Incidentally, I kept wi-fi disabled on the PC in order to not interfere somehow, although I don't know if this is strictly necessary. The Mac happily stayed connected to the internet via airport.

If you don't disable the wi-fi on at least one of the machines in this arrangement, you could end up with two separate networks connecting them together. Which would still most likely work, but you wouldn't be sure it was using the cable instead of the wireless link. So yeah, good idea to disable wi-fi at one end. For some reason I thought you'd disabled it at *both* ends so the potential for addressing conflicts (which cj_ correctly pointed out) would not have applied. Glad it's working!
posted by FishBike at 1:41 PM on June 7, 2009


« Older Should links open in a new window?   |   Areca Palm Newer »
This thread is closed to new comments.