Firefox update broke my themes and extensions.
December 1, 2004 10:03 PM   Subscribe

I broke Firefox. (mi)

I updated to Firefox 1.0 not too long ago and had some themes and extensions become incompatible in the process. So today, like an idiot, I switched to one of the incompatible themes. Now the browser window renders all goofy. No icons and everything is out of proportion. That's fine, except that the pulldown menus and all the preference windows render as blank, meaning I can't find my way back to the extensions and themes screen to switch back to the default theme. Is there a way to get rid of themes from within the Program Files directory?
posted by felix betachat to Computers & Internet (5 answers total)
 
Open Firefox in "Safe Mode." There should be an option in the Program folder on the Start Menu (on Windows, I'm sure something similar for OSX)

In Safe Mode, all extensions and themes are disabled. You can uninstall the themes you don't want, and go back to regular Firefox to discover that it's reverted to the standard theme.
posted by ALongDecember at 10:10 PM on December 1, 2004


That did it.

Thanks.
posted by felix betachat at 10:17 PM on December 1, 2004


For future reference, safe mode is invoked with the '-safe-mode' command line switch.
posted by cameleon at 2:17 AM on December 2, 2004


also, might want to uninstall themes and/or extensions when upgrading.
posted by Hackworth at 12:25 PM on December 2, 2004


Nah, extensions are automatically disabled on upgrade (because of a version number check). Not sure about themes, though.
posted by cameleon at 11:45 AM on December 3, 2004


« Older Who's your Benedict Arnold?   |   Pomona Students Newer »
This thread is closed to new comments.