The internet inside my router.
May 25, 2009 5:23 PM   Subscribe

My router (I think) keeps getting in the way of me and my internet! When I click on links, the browser will instead ask me to log into my router—the address bar reads http://192.168.1.254/testRouter?clear.

So, I've no idea why (only sometimes) any page can suddenly become http://192.168.1.254/testRouter?clear.

If I refresh the page, it happens again. Sometimes, I can go back, click the link again, and it'll work fine. Some days, this isn't a problem at all.

Google hasn't helped, mainly because I don't know what I'm asking. I just want to know how to not have this happen. This question seems similar to mine, but I don't want to sign up for a free trial when I have the hive mind.

MacBook running OS 10.5, wireless network through Netopia router. If I left anything out, just ask. Thanks so much!
posted by reductiondesign to Computers & Internet (7 answers total) 1 user marked this as a favorite
 
I have found two iterations of what you are looking for – here, and here.

It looks like one person's solution was to update the firmware on his router – here's Netopia's page.

However, if you're using a router supplied by your cable Internet company, then this can be problematic, as sometimes said companies do their own thing. In that case, you might want to instead call your cable company – often the customer service representatives can flash the hardware by remote.
posted by WCityMike at 6:37 PM on May 25, 2009


this page suggests that it happens instead of 404 when you have a malformed link:

http://www.broadbandreports.com/forum/remark,10744925

try this link does it happen?
posted by geos at 6:39 PM on May 25, 2009


Response by poster: WCityMike,

The router was supplied by our ISP; I've been away at college, and my dad said he already called them about this a few months ago. Evidently, this only happens on my computer now, whereas it used to happen on my parents' PC.


geos,

The incorrect link takes me to Safari's default "Failed to open page" screen.
posted by reductiondesign at 6:53 PM on May 25, 2009


It may also be doing a captive-portal thing of some sort. When you say you need to "log in", does it ask you to authenticate in some way (like, typing in a password)? It might be intended as a form of access control, so people can't drive by and use your network.
posted by hattifattener at 9:22 PM on May 25, 2009


Response by poster: After many hours of hiccup-free internetting, I'm pretty sure odinsdream's idea worked.

Thanks again, all!
posted by reductiondesign at 1:13 AM on May 26, 2009


You can change the DNS settings of your router so that it is utilizing any DNS server you want. It's probably worth fixing because you'll have to change the DNS on each computer/device that connects via your router.
posted by JuiceBoxHero at 6:42 AM on May 26, 2009


Taking odinsdream's idea a step further - for more robust DNS service, change your computer (and any others on the network) to use OpenDNS. The servers are: 208.67.222.222 and 208.67.220.220.

As a bonus - if you create an account with them, OpenDNS allow you to filter DNS responses to stop malware, phishing pages, adult content and other potentially undesirable content. They'll also report if they've seen any activity from your network that looks like Conficker.
posted by BOfH at 11:42 AM on May 26, 2009


« Older Umbrella recommendations?   |   It's got to be sexy funky ladies Newer »
This thread is closed to new comments.