Don't look into the light!
May 18, 2009 10:14 AM   Subscribe

I currently have an iMac 24" (early 2008). If you are acustom to the iMac you'll know that the brightness setting is extremely high. Unfortunately everytime I boot the computer up the brightness settings reset and I have to go through the hassle of lowering the brightness. Why is the keyboard/mac doing this? and can it be fixed?
posted by nam3d to Computers & Internet (8 answers total) 1 user marked this as a favorite
 
My MBP had been factory-set to automatically set the brightness according to ambient light. I turned this option off and now control the brightness on my own. I don't know whether iMacs even have this same setting, but if it does, you might just be able to turn that off (System Preferences -> Displays -> uncheck "Automatically adjust brightness as ambient light changes").
posted by so_gracefully at 10:32 AM on May 18, 2009


Not directly solving your problem but f.lux, is worth a look for adjusting the brightness of your screen.
posted by moochoo at 10:42 AM on May 18, 2009


shades I don't think I could use a mac without it.
posted by Lanark at 10:45 AM on May 18, 2009


If you don't already have an Apple keyboard with brightness keys right there, you can set an Fkey or other easy combination to raise/lower brightness. That'll reduce the hassle a lot. I fiddle with mine during the day/evening, depending on how tired my eyes feel.

System Preferences > Keyboard > Keyboard Shortcuts > Display
posted by rokusan at 10:58 AM on May 18, 2009


thanks for yours answers, but I'm still looking for that solution.

For the meantime another Mac user suggested running an apple script on startup to reduce the brightness, here is the code:

tell application "System Preferences"
activate
set current pane to pane "com.apple.preference.displays"
tell application "System Events"
set value of slider 1 of group 2 of tab group 1 of window "iMac" of process "System Preferences" to 1.0
end tell
quit
end tell

posted by nam3d at 11:49 AM on May 18, 2009


My old Powerbook had a similar problem. The solution? Don't shut down, just put the Mac to sleep. The power draw is minimal, it is ready to use much faster, and the brightness should hold constant when you next wake it up. I still follow this course of action with my new Macbook Pro - I haven't restarted in 45 days. OS X is a robust system that does not require a restart every day.
posted by prefrontal at 12:22 PM on May 18, 2009


Have you tried resetting your PRAM?
posted by wongcorgi at 12:45 PM on May 18, 2009


wongcorgi I have yes.
posted by nam3d at 2:36 PM on May 18, 2009


« Older Custom bicycle...is my dream impossible?   |   PsychologyFilter: Is this called projection? Newer »
This thread is closed to new comments.