Can't boot AMD BIOS w/ plugged-in USB hard drive?
April 27, 2009 6:15 PM   Subscribe

Why can't I boot my computer (even past BIOS) with a USB hard drive attached?

The BIOS POST test doesn't even complete- it doesn't get to the point of autodetection of the IDE chain- if I have a USB hard drive attached. Unplugging the device allows the system to continue to boot. I've tried turning on/off "USB Legacy Support" in the BIOS, no go. Any clues?

I have a Gigabyte motherboard (GM-MA74GM-S2) running AMD BIOS RS740. This is a server, so it's kinda sorta essential for that drive to be plugged in all the time.
posted by xmutex to Technology (11 answers total)
 
Umm, this is sort of ultra-basic stuff (that's the stuff I usually discover, face-slappingly, that I did wrong), but... is the machine set to boot to the USB drive? If so, and if the USB drive is anything non-bootable, then it won't start. If that's the situation, just edit the boot settings in the BIOS so that the boot order is CD-ROM -> hard drive, disabling booting from USB.
posted by koeselitz at 6:27 PM on April 27, 2009


[I only say that because my own machine won't boot with a USB drive plugged in either unless I unset that setting.]
posted by koeselitz at 6:28 PM on April 27, 2009


Nah, koeletiz, the only thing in the boot priority list is the (internal) hard drive. No USB nothin' in that list.
posted by xmutex at 6:28 PM on April 27, 2009


What model drive is it? There might be a firmware update that fixes this type of problem.

Also, did you try to boot another computer with the USB drive connected?
posted by pombiki at 6:48 PM on April 27, 2009


I had the same problem (with a gigabyte mobo, too) - I attached the USB headers wrong. Verify the USB connections on all of your ports (not just the one the HD is plugged into).
posted by bensherman at 6:48 PM on April 27, 2009


How big is the drive? I have had this same problem with a USB hard drive dock (ASRock mobo, don't recall what BIOS). It would boot with a 160GB drive attached, but not with a 750GB. My guess is your BIOS sees the drive and wants to check it out (somehow), but isn't designed to handle drives that big (at least via USB Mass Storage).
posted by neckro23 at 7:51 PM on April 27, 2009


Try putting a powered USB hub in between the drive and the computer.
posted by Chocolate Pickle at 7:55 PM on April 27, 2009


This is an odd story.... turning off "USB Legacy" in BIOS allows me to boot, but then Linux cannot recognize the drive. Then I must unplug,replug the device before it assumes /dev/sde. Both outcomes suck!
posted by xmutex at 8:10 PM on April 27, 2009 [1 favorite]


Yeah, I think what might be happening is that it provides a way to boot off the USB drive by scanning the bus and making them appear as IDE devices (which is why it's probably stuck at listing them). There's likely something wrong with the the firmware on either device, and I'd recommend upgrading both your BIOS and USB drive (typically there's a small microcontroller on there acting as a USB-to-IDE or USB-to-SATA bridge).
posted by spiderskull at 10:22 PM on April 27, 2009


My PC started doing this exact same thing recently, two days before the Maxtor external drive died. Might be worth backing that sucker up.
posted by punilux at 4:20 AM on April 28, 2009


Yeah, USB Legacy is the option. This is a common problem -- I've even seen systems where USB printers hang up POST, just because they have a small amount of storage. Basically, the BIOS is waiting to see if the USB device is a harddrive, and if it can boot. By the way, the system probably would boot if you waited a very long time.

You could probably put an entry in /etc/fstab using the UUID of the drive to have it auto-mount on /dev/sde. You can get the UUID with vol_id --uuid /dev/sde after the device is connected. The follow the format of the other drives in /etc/fstab to make the new entry.

Good luck! Let us know if you hit any snags.
posted by mad bomber what bombs at midnight at 2:50 PM on April 28, 2009


« Older Swine Flu Fallout   |   "The sunrise is a strip-tease between night and... Newer »
This thread is closed to new comments.