Can't get new laptop to connect to wireless network
April 11, 2009 2:57 PM   Subscribe

Cannot get new laptop to connect to secured wireless network! Arrghh!

The setup: Linksys WRT54G router; desktop physically connected to the router; old Fujitsu laptop with wireless connection that is working just fine; and brand-new Samsung N110 netbook that Will. Not. Connect.

The problem appears to be with security, since it *will* connect to public wireless nodes--and it will also connect to this router if I have security disabled. I'm not crazy about running an unsecured network, however.

I've been using WPA-PSK security. I have gone into the web interface for configuring the router settings, checked the WPA key, and typed it with great care into the relevant fields on the setup screens in the netbook, multiple times, with no success. I don't think it's a problem with me typing in the wrong key.

As noted, the old Fujitsu laptop continues to connect just fine with security turned on, so I don't think it's some pervasive problem with the router.

I've tried turning off Windows Firewall on the netbook--makes no difference. I've tried multiple instances of rebooting everything, and repairing the connection.

I tried all the steps listed at the Linksys Knowledge Base. When I physically connect the netbook to the router and check IP address, I get; desktop is same string ending in 100, Fujitsu laptop is same string ending in 101. When I ping the router from the netbook, no packets get lost.

Desktop and old laptop use Windows XP SP2, new netbook uses XP with SP 3; I can't think why this would make a difference, but I throw it out there.

I would be extremely grateful for any ideas or suggestions. Thanks!
posted by Kat Allison to Computers & Internet (15 answers total) 1 user marked this as a favorite
Response by poster: Oops, sorry, forgot to include that in the Tale of Woe: I tried setting the router security to WEP instead, carefully typed WEP key into relevant fields on netbook, and -- no dice. That didn't work either.
posted by Kat Allison at 3:02 PM on April 11, 2009

Can you connect with no security enabled? Does the router have the most up to date firmware available?
posted by gergtreble at 3:13 PM on April 11, 2009

this might seem crazy. but try entering the WPA key in upper-case.

This once worked for me. don't ask me how.
posted by TheOtherGuy at 3:20 PM on April 11, 2009

Response by poster: Yup, it connects just fine with security off. I tried downloading firmware from the Linksys site, but it downloads as a .bin file, and I'm having trouble getting it to open (my computer seems hellbent on trying to open it with VLC media player, for reasons that elude me).
posted by Kat Allison at 3:20 PM on April 11, 2009

googling tells me that WPA keys are case sensitive. i never knew :)
posted by TheOtherGuy at 3:22 PM on April 11, 2009

Response by poster: Tried it in upper case -- no luck. Sorry!
posted by Kat Allison at 3:26 PM on April 11, 2009

Perhaps your router is filtering by MAC address (that's under advanced/network filter)?
posted by Neiltupper at 3:34 PM on April 11, 2009

Response by poster: Hmm... well, when I look at the "Wireless" -> "Wireless MAC Filter" tab in the Linksys configuration, it shows as "disabled," so I'd guess the router isn't doing that. (Is there something on the netbook settings I should check, though?)
posted by Kat Allison at 3:39 PM on April 11, 2009

Kat. You don't need to open the .bin file on your computer. You need to upload it to the router on the routers "update" page. It should look something like this.
posted by gergtreble at 3:40 PM on April 11, 2009

More info here.
posted by gergtreble at 3:45 PM on April 11, 2009

Response by poster: gergtreble: Thanks very much! That got the upgrade uploaded. However, I rebooted everything and still no connection. *sigh*
posted by Kat Allison at 3:57 PM on April 11, 2009

If it makes any difference, I have the same router with the same problem. My solution: buy another router.

Before I do that, I'm going to experiment with Tomato Firmware, which was designed specifically for this cruddy, shitty species of router.
posted by KokuRyu at 4:09 PM on April 11, 2009

Have you tried updating the driver for the wireless card? Some Googling reveals that many people have had trouble with this particular card (Atheros ar5007eg) and updating the drivers sometimes fixes it. You can download the latest drivers for the N110 here.
posted by jbullion at 4:21 PM on April 11, 2009

Response by poster: HOO-hah! Solution! I finally got on chat with a customer service rep, who suggested changing the WPA key (buh? had no idea you could do that) -- and once I did that, I was able to connect.

Thanks to everyone who commented! Special thanks to gergtreble for helping me understand how to update firmware, and my sympathies to KokuRyu for undergoing similar hassles.
posted by Kat Allison at 4:24 PM on April 11, 2009

Response by poster: Oh, and on preview -- thanks, jbullion! I will do that as well, right away.
posted by Kat Allison at 4:24 PM on April 11, 2009

« Older If a german laughs in the forest....   |   My backpack is crushing my sciatic nerve Newer »
This thread is closed to new comments.