Itunes is turning single albums into multiple, please?
March 30, 2009 12:01 AM   Subscribe

Trying to organize my iTunes library, but I'm going crazy. Itunes is displaying one album as multiple albums.

Rather than trying to explain it, I've taken screenshots. Here is what I want to happen. But, this is what is happening to a very large number of albums.

I've checked my ID3 tags, and the album name is identical for each album. Has anyone had this happen to them? Is there an easy way to fix it? Any help would be very appreciated.
posted by ComeUndone to Computers & Internet (9 answers total) 2 users marked this as a favorite
Best answer: Try setting 'Album Artist' to be the same thing (i.e. 'Death Cab for Cutie') for all the tracks. That's worked for me in the past.
posted by chbrooks at 12:16 AM on March 30, 2009

Best answer: Maybe not your exact case, but I can share what has happened to me and how I fixed it:

I had some albums that appeared as multiple albums in iTunes, I don't know why it happened. So, I went into the "get info" of only one song and made a "copy" of the album name. Then I went back to the normal view and selected *all* of the songs on that album (including the one I had just worked on) and then "pasted" the album name into the album field. This updated that field for all the songs at the same time, and fixed my situation. Hope this helps.
posted by alchemist at 12:16 AM on March 30, 2009 [1 favorite]

as chbrooks also mentioned it could be the album artist that's giving the problem - so i've also done what I wrote about for that field.
posted by alchemist at 12:17 AM on March 30, 2009

Response by poster: Both of these solutions worked. Thank you.
posted by ComeUndone at 12:18 AM on March 30, 2009

When I've had similar problems, I checked carefully and found out there was an extra space in the title of the album on some songs in the album, so iTunes read it as two different titles. If that is indeed your problem, you can fix this by selecting all songs in that album, 'get info' and apply re-write the album title in the appropriate field.
posted by bluejayk at 12:19 AM on March 30, 2009

Have you got an extra space in an ID3 tag there somewhere?


Try searching by artist, selecting the relevant songs as a group (as in highlight them all in blue) then right click (command-click on a mac?) to get to the "Get Info" where you can bactch edit the ID3 tags and then remove and then re-add the album title *from all the tracks*.

Maybe that will trick iTunes into re-sorting the songs.
posted by tiamat at 12:19 AM on March 30, 2009

Another tip, especially for albums that have slight variations in artist names, spelling mistakes etc. Select all the songs from the album, hit Apple - I then look for a checkbox/dropdown thing that says 'Part of a compilation' and tick it. iTunes will then treat them as a single album.
posted by Happy Dave at 2:18 AM on March 30, 2009 [1 favorite]

Rap albums often get screwed up by iTunes, since you have things like "Lil Wayne," "Lil Wayne feat. Jay-Zee," etc.
posted by bardic at 3:54 AM on March 30, 2009

I know you've solved the problem, but for people who might stumble across this in the future, one last thing that can cause albums to be "split" is the track numbering—if one track is tagged like "Track 1 of 12" and the others are just tagged "Track 2," "Track 3" (etc), the album can appear split or in the wrong track order.
posted by bcwinters at 8:00 AM on March 30, 2009

« Older Closed Captioning for online video   |   Thin, angled prostate massager or other tool for... Newer »
This thread is closed to new comments.