How to get my motherboard to recognize all 6GB of RAM
March 14, 2009 5:25 PM   Subscribe

New Asus P6T motherboard only showing 4GB of RAM in BIOS when I have 6 installed. :(

Hey everyone! Just built a new PC last weekend specs are as follows:

-Antec 900 case
-Asus P6T Mobo
-Intel Core i7 920 CPU
-3x2GB Corsair XMS3 DDR3 RAM
-Vista 64-bit
-ATI Radeon 4870 1GB

I have the memory slotted in DIMMs A1/B1/C1 as listed in the manual for the P6T. When I boot into BIOS (and Vista 64) it only shows 4GB of RAM total. I've tried looking everywhere for possible disabling of memory reallocation etc but I haven't been able to find any way to switch this on and off. I don't think any of the modules are faulty but I will admit I'm not that experienced with RAM optimization.

Is it possible I may have to set voltages etc manually. I've heard/read that DDR3 takes more voltage than standard DDR2 RAM. Mobo BIOS was flashed to most recent (which was released March 6, I built it all the 7th lol) Any help would be most appreciated as I'm really super eager to get all 6GB working :(
posted by PetiePal to Technology (7 answers total)
Test each module individually (i.e. take them all out, then power the board with 1 module in A1) to make sure they're all working OK?
posted by ArkhanJG at 5:39 PM on March 14, 2009

Are you sure you're in 64-bit mode? The first thing I'd do is look through all the BIOS menus to see if there's one controlling that.
posted by Chocolate Pickle at 5:51 PM on March 14, 2009

Doesn't the memory have to be added in pairs? You list 3x2Gb RAM modules in your specs. Try adding another module to round out to 4x2Gb modules.
posted by cjseymour at 7:31 PM on March 14, 2009

As ArkhanJG mentioned, make sure all your memory is good by swapping the chips.

If that doesn't work, you may have a mobo/RAM compatibility problem. My Asus board (P5Q) had trouble supporting my 4x2GB DDR2 RAM (I forgot which brand) until I set the voltage to 2.1V. Even then, it wouldn't boot sometimes; if I reduced the RAM to 2x2GB it worked, though. Flashing the motherboard fixed the problem, which was mentioned in the release notes of the flash update as "enhances compatibility with some RAM" or something like that.

Check again to see if a new BIOS is out for your mobo yet. If flashing the mobo isn't an option, you can try different voltage settings (research on Asus forums or web first), or switching the RAM for a different brand/speed. You may also want to report the problem to Asus and see if they issue a motherboard BIOS update in the near future.
posted by Simon Barclay at 7:45 PM on March 14, 2009

The Core i7 series will accept matched triplets, and you're supposed to use 1.6V max:
posted by Caviar at 8:13 PM on March 14, 2009

There have been frequent BIOS upgrades for that board, mostly dealing with memory issues. Fortunately, Asus has made it dead simple to upgrade it.
posted by ae4rv at 6:20 AM on March 15, 2009

Response by poster: The memory is Corsair XMS3 DDR3
Tr3X6G1600C9 1.65V ver 1.1

My mobo does support X64, and I have Vista 64 installed.
posted by PetiePal at 12:17 PM on March 15, 2009

« Older Best books on the middle ages?   |   How can I make a splash page for a Wordpress site? Newer »
This thread is closed to new comments.