Why does copying files from CD to my harddrive slow down my entire system?
November 1, 2004 6:28 AM   Subscribe

Plextor CD-R - Copying files to harddrive sloooowwwws computer way down. [mi]

I have a plextor CD-R drive. When I write to it I throttle the write time to 4x or 8x otherwise it slows my system down drastically (to the point of being unusable). That is OK, because I have a solution.

Now, when I copy files from a CD onto my harddrive (like a sic of mp3s) it totally renders my system incapacitated while copying. Is there a way to throttle the read speed? I would rather set these copies up in the background and be able to work while they are going than to have to twiddle my thumbs.
posted by pissfactory to Computers & Internet (3 answers total)
You shouldn't really have to throttle the drive like that. It shouldn't slow down the system that way if it's working properly.

It could be that you don't have DMA turned on for IDE. Assuming you're running Windows (XP, but others should be similar), go into the Device Manager, IDE ATA/ATAPI controllers, Primary and Secondary IDE channels, go into the properties and look at the Advanced Settings tab. Transfer mode should be 'DMA if available' and the current transfer mode should be some variety of 'Ultra DMA'.

If that doesn't work, check the cables and jumper settings. (The hard drive(s) need to be on 80-pin cables.) Put the CD-R drive on a separate IDE channel from the hard drive(s) if possible.
posted by mcguirk at 7:22 AM on November 1, 2004

What mcguirk said, the cd drive might be in PIO mode, which chews up lots of CPU power.
posted by borkencode at 8:13 AM on November 1, 2004

Why is this a choice? Who needs to leave their system in PIO mode?
posted by stuart_s at 8:36 AM on November 2, 2004

« Older How do I transfer a large number of emails from...   |   Can you help my kid hack his X-Box? Newer »
This thread is closed to new comments.