XML-RPC posting throws up error
February 5, 2009 12:44 PM   Subscribe

Why can't I get a wordpress.org blog to enable XML-RPC posting?

I installed a new version of Wordpress on a subdomain (history.keithkeirstead.com). I was setting up and checked the box for XML-RPC posting when I clicked save changes it sometimes gives me a 403 forbidden error or it will redirect me to the blog and says sorry no posts can be found. Everything else seems to work fine, I can update sidebar, add new posts but just not enable XML-RPC posting. So far I have tried it with different themes, deactivating all the plugins and deleting everything and completely reinstalling wordpress, but I still get the same error. Does anybody know why this is happening or how to fix it?

Ive Googled around and found no errors like this, and posted on the wordpress forums but they seem less then helpful so I turn to the hive mind to hopefully help, Thanks!
posted by lilkeith07 to Computers & Internet (3 answers total)
 
Best answer: Ask your host. That file is frecuently blocked to avoid security problems.
posted by Memo at 12:54 PM on February 5, 2009


Best answer: It's a holdover from several years back, when numerous hosts were compromised by a widespread XMLRPC security hole. If your host is DUMB, you might just be able to rename the file to something like 'metapost.php' instead of xmlrpc.php; setting the endpoint to that URL in your blog client can sometimes fix it.

The real solution is to get them to unblock it.
posted by verb at 8:10 AM on February 6, 2009


Response by poster: It seems that my host my have blocked it however I was able to go in through phpmyadmin and go to the options table and manually set it from there. Thanks!
posted by lilkeith07 at 9:05 AM on February 6, 2009


« Older Vox populi   |   How to recap high school math within a month? Newer »
This thread is closed to new comments.