what the shit
January 16, 2009 7:38 AM   Subscribe

weird linux cursor problem. I'm having this problem with an ssh terminal where the cursor won't advance past the last character in a line, so I can't change or delete the last character.

This is thoroughly annoying, but Google searches are not helping me. In otherwords, say i want to alter a previous command. I hit the up arrow and it brings up that command, but then I can't change the last character as the cursor just stops there.
Is this a local setting or something? I am using SSH Tectia client and Debian Linux.
I can't figure out what is causing this or what changed.
posted by alkupe to Computers & Internet (14 answers total) 1 user marked this as a favorite
 
you may be using vi history. try [esc] - a - foo.
posted by ezekieldas at 7:53 AM on January 16, 2009


Yeah, I have that problem too. I just copy and paste.
posted by kindall at 7:55 AM on January 16, 2009


What is your $SHELL on the remote host?
What is $TERM set to? What terminal type is Tectia set to?
What is the output from an "stty -a"?
posted by nomisxid at 7:55 AM on January 16, 2009


echo $SHELL = /bin/bash
echo $TERM = vt100
ssty - a =
speed 38400 baud; rows 49; columns 138; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = ; eol2 = ; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R;
werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke

posted by alkupe at 8:04 AM on January 16, 2009


are you escaping to get into the buffer?
posted by plexi at 8:30 AM on January 16, 2009


also, if you are doing an insert you wont be able to get past that character - try an append instead
posted by plexi at 8:31 AM on January 16, 2009


Try swapping between "set -o vi" and "set -o emacs". Do either of those give you the functionality you were used to?
posted by nomisxid at 8:46 AM on January 16, 2009


set -o emacs works.
thanks!
posted by alkupe at 9:15 AM on January 16, 2009


in case anyone else has this problem, I fixed it permemently on this machine by editing $HOME/.bash_profile and putting in that line "set -o emacs". Man was that driving me crazy.
posted by alkupe at 9:26 AM on January 16, 2009


There is a sequence of keys that can put you in vi mode at the bash prompt. While I don't remember it off the top of my head, beware of it - even with that setting in your .bash_profile, you can still accidently end up in vi mode.

:wq!
posted by bensherman at 11:38 AM on January 16, 2009


Wait a second! I want to know how to get into vi mode.
posted by low affect at 1:44 PM on January 16, 2009


Wait a second! I want to know how to get into vi mode

Just hit escape.
posted by plexi at 2:45 PM on January 16, 2009 [1 favorite]


zsh FTW!
Good call, nomisxid.
posted by funkbrain at 8:51 PM on January 16, 2009


Here are instructions on using vi mode in bash.
posted by PueExMachina at 9:48 PM on January 16, 2009


« Older Help with Handbags   |   Do I have to choose functional over pretty? Newer »
This thread is closed to new comments.