How do I get streaming web videos to stay full screen on a second monitor?
January 4, 2009 4:18 PM   Subscribe

How do I keep a web window full-screen on one monitor while working on another?

So basically I have just hooked up my old 32" CRT TV to my PC via S-video as a second monitor.

One thing I want to be able to do is have Youtube / Joost / whatever-streaming-webs-source videos playing full screen on the TV whilst working on my PC.

Whilst this works with keeping apps (e.g. VLC / windows media player) full screen, when I play a flash video via Joost or Youtube in Firefox and expand it to fullscreen on the TV, it just collapses back down again the moment I click anything on my primary monitor.

I tried searching around and couldn't find an obvious solution for this - anyone have any bright ideas?

Thanks in advance!
posted by inbetweener to Computers & Internet (8 answers total) 5 users marked this as a favorite
Unfortunately, I think you may be out of luck. The fullscreen behaviour is built-in to the flash player and is set to work in this fashion (sites and users have no real control over this part). The player will also pop out of fullscreen mode if another application demands focus (with an alert window or whatnot).

If the site was displaying the video by opening a new browser window and scaling the flash movie to 100% you'd be fine, but you'll rarely find this. The advantage to using the built-in fullscreen method is hardware acceleration.

I'll have a quick look around, but I don't think there's a solution. A strange workaround could be to zoom that portion of the screen ; on the Mac, this is usually done by holding down Option or Command and moving the scroll wheel. I'm not sure what the equivalent on Windows is. It's a pretty rubbish workaround though!
posted by sektah at 4:41 PM on January 4, 2009

Apparently unchecking "Hardware Accelerating" fixes it. Right click on the video, Settings.
posted by nitsuj at 4:42 PM on January 4, 2009

Also -- and this is a bit weird -- I asked this same question nearly three years ago. Strange thing is, I didn't remember asking it, and only came across it when searching Google for an answer.
posted by nitsuj at 4:47 PM on January 4, 2009

somebody else had the same issue here:
(no resolution)
I don't know enough about auto hot key scripts.. but somebody here might..
and this may help, but I am no coder:
posted by defcom1 at 5:16 PM on January 4, 2009

A shot in the dark- Can you change your display settings so that the TV is considered the primary monitor?
posted by PueExMachina at 5:42 PM on January 4, 2009

A lot of apps don't play nice with multi-mon. This may be one of them where it assumes if you clicked outside it, it should go back to how it was.

I use Windows Media Center on my secondary display (which is also a TV, but attached via dsub VGA connector) and it stays full screen just fine. I often watch netflix on-demand stuff in IE full screen on that monitor as well (yeah silverlight).
posted by jeffamaphone at 6:47 PM on January 4, 2009

On your display properties - settings tab, select the second monitor from the drop down list and then uncheck "Extend my Windows desktop onto this monitor". I think unchecking this will make your computer treat your monitors as an individual screens rather than treat both as one wide screen. Then you can maximize a window on monitor 2 while working normally on monitor 1.
posted by atm at 8:47 PM on January 4, 2009

for netflix on a mac go to settings / displays and drag the white bar over to your 2nd monitor..full screen will now open on that 2nd monitor.
posted by pinto at 8:10 PM on March 28, 2009 [2 favorites]

« Older How can I achive Gmail zen across my Mac and...   |   Learning art skills? Newer »
This thread is closed to new comments.