Mac Defaults to QuickTime
October 15, 2004 7:17 AM   Subscribe

Potentially-really-obvious-mac-question-filter. Why does Safari want to open MP3 streams in QuickTime no matter what I do - and how can I stop it?
posted by ascullion to Computers & Internet (8 answers total)
 
Same happens for me in IE / Win - seperate page with a quicktime player on it. Any advice on how to stop that?
posted by Pericles at 7:56 AM on October 15, 2004


System Preferences.
Quicktime.
Plugin tab.
MIME Settings button.

Uncheck whatever you don't want Quicktime to handle.
posted by Remy at 8:17 AM on October 15, 2004


You should just be able to change what the default helper app is for .mp3 or audio/mpeg to what you want to play them.

Not sure about Windows, but on Mac, this might help.

(On preview: Ah, Remy's way seems more specific. RCDefaultApp is still a great utility to handle a function that's a bit hidden in MacOS, so I won't re-edit)
posted by jammer at 8:23 AM on October 15, 2004


jammer, you are my HERO! I've been looking for something to handle that for a long time...
posted by mkultra at 8:34 AM on October 15, 2004


In Windows, open any folder, go to Tools in the menubar, from there pick Folder Options, pick the File Types tab, scroll down to MP3 and click Change to change the player MP3s are associated with. If it's already associated with another player, go to Control Panel > Quicktime and follow Remy's suggestion.
posted by riffola at 8:51 AM on October 15, 2004


System Preferences.
Quicktime.
Plugin tab.
MIME Settings button.

Uncheck whatever you don't want Quicktime to handle.


I did that before I posted the question.. but Safari still opens the streams in QT. All of my MP3 files open in iTunes.

RCDefaultApp seems really useful, will try it out - thanks
posted by ascullion at 8:59 AM on October 15, 2004


If you don't mind downloading the file first, hold down option and click on the link to the MP3 file. This will put it in you default download folder. Then select File->Get Info, for the MP3 file within the Finder. Once it opens, click the triangle next to Open with: and select iTunes as your default application and select Change All...

This will not change how Safari handles MP3 files when you click on them directly, however any MP3 you open from the Finder should open within iTunes.
posted by the biscuit man at 9:45 AM on October 15, 2004


This will not change how Safari handles MP3 files when you click on them directly

Yeah, that's what I've found. I'd like to set up a few radio streams as bookmarks, but can't get them to behave the way I want.

Macs are very user-friendly until you want to do something that doesn't fit in with their business model..
posted by ascullion at 11:44 AM on October 15, 2004


« Older My system clock (on Win XP) creeps forward every...   |   What's your favorite Apache log analyzer? Newer »
This thread is closed to new comments.