Microsoft Exchange Hates Me
December 10, 2008 11:15 AM   Subscribe

We have Microsoft Outlook set to send emails via a POP3 service, but our old Exchange 5.5 server keeps trying to take over when we don't want it to.

First the setup:

Our company's Exchange 5.5 server is having too many issues shaking hands with other email servers and has been blacklisted too many times, so we're deciding to take it down and set all our employees on POP3 mail, managed with Outlook (some on 2k2(xp), others on 2000) as a client.

We can't get rid of Exchange 100% as of now (though we will eventually) since a lot of our employees rely on the Global Address contacts, and some use the calendar for scheduling meetings and such. Until we devise a method for scheduling meetings/reminders and possibly keeping a centralized contacts list sans Exchange, we'll get rid of it. But as of now, this is the setup:

~Exchange 5.5 with internet email services disabled (but internal email enabled).
~100+ employees on Outlook 2000-XP(2002?)
~Outlook is set to retrieve internal mail and global contacts via Exchange
~Outlook is also set to send/receive POP3 mail as the primary send/receive source
~User's *.PST file is saved offsite their machine into another server
~Some OFFSITE employees were deleted from Exchange's Global Address list and placed instead on the user's local Contacts list. So all contacts in the local Contacts lists are offsite people.
~Our POP3 service provider allows us to keep the same domain name (***@company.com) on our POP3 that our Exchange server uses.

Now the problem:

Exchange is giving us hell by constantly trying to intervene on how the mail is sent. Even though we set Outlook to use POP3 as the primary send/receive account, AND even though we disabled the internet mail service on Exchange, Exchange tries to take over and send the email like a disgruntled mother-in-law, resulting in an "undeliverable" message from Exchange.

Now we realize that the Global Address list contains headers within the contacts that pertain to Exchange that would override our settings... but the local Contacts lists -created by yours truly- only contain the contact name and email address, and theoretically should not contain any exchange headers or reason for exchange to intercept our POP3's precious assignment.

Outlook 2002(xp) has an auto suggest feature that whimsically fills in the name of the contact you're typing. So the user is typing in Nancy (for example) and auto suggest returns "Nancy (e-mail)". Yay? Not so fast. Double click that entry and you find that it's got EXCHANGE all over the headers. So I deleted the auto-suggest cache file (*.nk2) from the user's local profile and the problem has disappeared. I can tell because auto suggest now gives us "Nancy (nancy@company.com)" instead of "Nancy (email)". So this issue is fixed... but only on people using Outlook XP(2002?).

I still have a ton of people on Outlook 2000 with a similar issue. This is a weird beast. There is no cache file I can delete (*.nk2) from what I know. Say we want to send something to Nancy again. We click the "To:..." button which brings us to our contacts selection screen. We go to the local contacts list, add Nancy, click ok, and now we're back at the main message screen, the "To:" field displaying "Nancy (email)". A double-click on this field takes me directly to the contact editor, which shows her name and email address correctly with no Exchange headers to be found. All good, right? But if I hit "Send" I get an "Undeliverable!" message with EXCHANGE ALL OVER IT OH GOD!!...

Now, we try again. We open up a new message, hit the "To:..." button. Get ready, this one's weird.... we go to the local Contacts list, select Nancy and hit the "To ->" button to add her as a recipient. If we double click her name in the "Recipients" box, (you ready for this?) instead of taking me to the contact editor like it did on the main message window, we see a window with bloody EXCHANGE all over the place, scrawled everywhere like blood in a
damned murder scene! I have NO IDEA where outlook is getting this info from or how to erase it.

Now, if I manually type in the recipient's email (nancy@company.com), POP3 happily does its thing without molestation. I really need help. If anybody can offer help and rescue me from a company lynching, it would be greatly appreciated.
posted by Zeker to Technology (8 answers total) 1 user marked this as a favorite
 
POP3 is *only* used for receiving mail, never for sending. You may need to rephrase the problem.
posted by devbrain at 11:37 AM on December 10, 2008


If your smtp server that is used for sending out through POP does not require authentication (it knows your IP because you check mail from it) you could set up Exchange's SMTP virtual server to use that external SMTP server as a Smart Host. That way it would still use your external server to send the mail, but would be transparent to users if they inadvertently sent through Exchange.

And as for Outlook 2000, its is an outrageously buggy version, I'm sorry you have to deal with it.
posted by ijoyner at 11:39 AM on December 10, 2008


Are you using public lists to make contact entries with full e-mail addresses? If so, you could go to Tools, Address book in Outlook, then go to Tools, Options. This is where you specify where Outlook is pulling its addresses from. You can remove the Global address list and just add the public list that has the full written addresses in them. You could also try to re-order the list and move the GAL down.
posted by ijoyner at 11:42 AM on December 10, 2008


For the sake of your sanity, since you're apparently handling e-mail for 100+ users without understanding the difference between POP3 and SMTP, you may want to call a contractor specifically versed in e-mail technology to help you sort this out.

In any case, ijoyner is probably on the right track - it's probably easiest to continue letting Outlook contact Exchange for mail delivery, but reconfigure Exchange so that it uses your ISP (or e-mail provider) SMTP server as a relay smart host. They can help you with the settings for this.
posted by odinsdream at 12:59 PM on December 10, 2008


POP3 is *only* used for receiving mail, never for sending. You may need to rephrase the problem. -- devbrain

Sorry man, let me clarify. We're using No-Ip for both our POP3 and SMTP services.

If your smtp server that is used for sending out through POP does not require authentication (it knows your IP because you check mail from it) you could set up Exchange's SMTP virtual server to use that external SMTP server as a Smart Host. -- ijoyner

No-Ip does in fact require authentication. We've also noticed that slowly but surely fewer and fewer places were accepting our Exchange's emails, even if we weren't on any blacklists. We think there's an update going around to most servers that adulterates communication between newer mail servers and older Exchange servers. Wouldn't that include communication between our Exchange server and No-Ip's servers?

Are you using public lists to make contact entries with full e-mail addresses? --ijoyner We do in fact have a public contacts list besides our global address list. Our goal, however, is to rid ourselves of Exchange and have everybody manage their own contacts on their PST, but right now our company is at a very busy point that doesn't allow room for a sudden switch. The global contacts list contains only internal email addresses, and all internal email works fine on Exchange. But our local contacts (all pointing to offsite email addresses) still have headers pointing to exchange, and only in outlook 2000.

To answer your question though, I've tried that procedure on Outlook XP and it works fine and especially after deleting the *.nk2 cache file (eliminates possibility of retrieving bad contacts from the global address list in the future), but on Outlook 2000 it still recalls Exchange headers hidden somewhere in the cache. I whanna know how go get rid of them or some quick way around this that doesn't give the user any extra work to send email because currently they have to type in the email address for it to go through. Also, licensing is an issue here so we can't just give everybody an updated Outlook :(

Thanks for the good ideas though, ijoyner, you're giving us other directions to try.
posted by Zeker at 1:24 PM on December 10, 2008


@odinsdream,

Oh hell, I messed up on my terminology, so for the sake of clarity, pretend I said "internet mail" instead of POP3 mail, ok?

--IT n00b
posted by Zeker at 1:28 PM on December 10, 2008


On the way towards your goal to replacing Exchange, you may want to investigate replacing Outlook with Thunderbird, then connect to an LDAP shared address book. I've not had any luck using Active Directory as an LDAP server, but you may want to check out Apache Directory, or some other non-free LDAP servers.

There are a wide variety of shared calendar applications. It would be my opinion that you separate the e-mail and calendaring functions, even though Outlook users may be initially put off by that.
posted by odinsdream at 2:41 PM on December 10, 2008


You could attempt to talk to your POP/SMTP host and see if they would allow your public IP to relay messages without authentication. I know that Exchange allows this, but they may not use Exchange on their end. Then you could use the smart host feature to relay messages over to your external hosted SMTP server.
posted by ijoyner at 12:23 PM on December 11, 2008


« Older Clothing mess - how to solve?   |   Girls Gone...Mild? Newer »
This thread is closed to new comments.