Please Stand By... or not.
November 23, 2008 1:46 PM   Subscribe

My home-built computer running Windows XP will not enter Stand By or Hibernate mode. Why?

I have been having this issue for a while now, and it persists even after I have completely formatted and reinstalled Windows.

I have "Enable hibernation" checked in the Power Options control panel.

When I click "Turn Off Computer" and then click the "Stand By"/"Hibernate" button, the "Turn off computer" window goes away, and nothing happens. The computer continues running normally.

I have been previously able to use both Stand By and Hibernate, and I don't know or recall what might have triggered this switch in behavior from the system.

I am running XP with service pack 2, and most of the current updates. The computer is one I built myself. The reformat was a last-ditch solution to a random rebooting problem (which became compounded by other problems) that I was experiencing.

The last time I ran Windows Update (last night), it installed all the recommended patches but said the following would/could not be installed:

Security Update for Windows XP (KB890859)
Security Update for Windows XP (KB914389)
Microsoft .NET Framework 1.1 Service Pack 1

It also failed to reboot the computer completely after installing the updates, such that when I pushed the power button on the computer this morning, it first came up with a "Windows is shutting down" dialog box and then restarted.
posted by digitaldraco to Computers & Internet (9 answers total) 1 user marked this as a favorite
 
ACPI turned on/configured in the bios? Might be worth looking for an updated bios if you havnt updated recently.
posted by wavering at 1:50 PM on November 23, 2008


Have you checked to see if you have any unknown devices in "Device Manager"? Usually when there is an issue with sleeping on a computer, the SM Bus for the motherboard/chipset is not installed or is malfunctioning. A good rule of thumb is just to make sure you never have any hardware components under "Other" or "Unknown" or with a question mark.

If this is the case, then just track down the drivers you need to get this functionality to work.
posted by cgomez at 1:50 PM on November 23, 2008


wavering: Where would I find that option in the BIOS?

cgomez: No unknown/other devices in Device Manager. I recently uninstalled SP3, and the Stand By option was greyed out, but re-installing my graphics driver resolved that issue. No other devices have or had question marks.
posted by digitaldraco at 2:00 PM on November 23, 2008


I was having a problem with this with my new computer (which has vista) but when I moved and was without internet service for awhile, it started going to sleep again. When I got internet service, I started running an experiment, and sure enough, if the modem was on the computer wouldn't go to sleep. Since my new modem has a big on off button on the front of it now, I just hit the off button if I'm about to leave the house for awhile and everybody's happy.
posted by Kiablokirk at 2:17 PM on November 23, 2008


"I moved and was without internet service for awhile, it started going to sleep again"

Winxp has a wake on lan option that might be preventing the computer from ever getting to sleep if you have constant network activity. There is some way to turn this off but I don't know it off the top of my head.
posted by flug at 2:40 PM on November 23, 2008


You're going to have to look around, every bios is different. You're probably looking for any "off" or "disabled" power management settings. Just write down what you do so you can always undo it later.
posted by wavering at 3:15 PM on November 23, 2008


Weird Windows power-down issues are often caused by Wake On Something BIOS settings that are turned on by default and which you don't need. If you have Wake On LAN, Wake On Modem/Ring, Wake On Alarm or Wake On Any Other Bloody Thing turned on in your BIOS (generally you will find these in a Power page or tab) try turning them off.
posted by flabdablet at 5:18 PM on November 23, 2008


When I selected Restart to get into my BIOS, the system hung for a bit and then entered Hibernation mode (after I'd clicked that option hours ago).

In the BIOS, under "Power Management", there is a "PME Event Wake Up" option that is currently enabled. All other power/resume options are disabled.

My Google-Fu is weak on this; I couldn't find a clear definition of what that option does, nor what a PME event is, exactly.
posted by digitaldraco at 10:02 PM on November 23, 2008


Disabling the PME option did nothing. The system still won't enter Stand By, nor Hibernate.

However, Restarting made the system enter Hibernate again.
posted by digitaldraco at 10:09 PM on November 23, 2008


« Older The illusive ham cheese!   |   Stock sound archive? Newer »
This thread is closed to new comments.