How do I persuade OpenOffice to show when a space has been typed?
October 24, 2008 9:01 AM   Subscribe

How do I persuade OpenOffice Writer to move the cursor when a space is typed at the end of a document? It's driving my neighbour mad and he's kindly sharing this madness with me.

When typing a document, the cursor simply doesn't react when the spacebar is pressed but moves ahead once a letter key is pressed. What this means is that my neighbour doesn't know whether the software has registered the space bar until he carries on typing and has to go back to insert spaces if it hasn't (there's a separate issue here about the spacebar on his keyboard).

I found what I thought was the answer but while this has stopped the problem of getting multiple spaces when he presses the spacebar repeatedly - unsure whether it registered the first, second or nth time - the cursor still doesn't move until a character is typed (at which point it shows the space and the character).

I know this all sounds like a very minor niggle but I can only say that it's hard to appreciate just how annoying it is until you've experienced it for yourself.

There must be a way to get OpenOffice Writer to behave in what I'd think is a more user-friendly manner but I just can't find it.
posted by Lionel d'Lion to Technology (5 answers total)
Can you give steps to reproduce the problem? I can't replicate this on a fresh OO 2.0.2 install under windows. What OS? What version of Open Office?

One obvious workaround would be to turn on non-printing characters. If you see a new dot, a space was entered. After a few months, I don't even notice the clutter and my anal retentive side loves knowing there's no stray tabs or spaces.
posted by cowbellemoo at 9:20 AM on October 24, 2008

Response by poster: It's a new Vista PC that he's using. I don't know the version number of OO but will get this, probably in the morning.

I've shown him the non-printing characters option but even with these being displayed, the space doesn't appear on screen until a "proper" visible character has been typed.
posted by Lionel d'Lion at 9:27 AM on October 24, 2008

Mine does this randomly... Restarting OO fixes it for me.
posted by magikker at 10:34 AM on October 24, 2008

Ugh, it does the same thing for me. Strangely enough, this behavior also appears when I use the Google writer.

This problem and the horrible startup times are the only things keeping me from ditching Microsoft Office.
posted by Willie0248 at 10:50 AM on October 24, 2008

Doesn't do it for me on a fresh install of the new 3.0 release, which, by the way, starts up a lot faster.
posted by zsazsa at 12:00 PM on October 24, 2008

« Older Easiest way to move files and programs?   |   Need Stock a Flash! Newer »
This thread is closed to new comments.