Drive-side AutoRun Disabling
October 18, 2008 1:24 PM   Subscribe

Is there a way (on the USB drive side) to keep Windows from prompting the user to decide what to do with the files on a newly connected USB drive.

When one connects a USB drive to a computer. Windows prompts the user, asking what you'd like to do with this new drive. I know how to disable that on the OS side, but if I'm connecting this drive to someone else's computer, is there anything I can put on the drive to keep Windows from looking through my files and deciding what I may want to do?

At the conference room computer, my USB drive was connected and that windows autorun prompt appeared. The guy running the meeting just clicked OK or something to get rid of it, and one of the pictures two or three folders deep came up. It was nothing embarrassing, but I never really know what's on that drive, and I'd like to avoid that risk.

If I can't get Windows to ignore the drive entirely, is there a way I can restrict certain folders or files? Ideally, this would work something like robots.txt where I could simply add a text file with what I want Windows to ignore. I'd like to avoid password protecting anything on the drive.
posted by SAC to Computers & Internet (11 answers total) 2 users marked this as a favorite
The only way I can think of is if you could fool Windows into thinking that it is not a removable drive, while at the same time providing access to it as a drive. In other words, autoplay doesn't popup for hard drives connected to SATA/IDE, so tricking Windows into thinking your USB drive is a regular hard drive would get around the prompt. How you'd go about this is way beyond me.
posted by wastelands at 1:46 PM on October 18, 2008

Go to the Start menu, choose Run.. and type gpedit.msc to bring up the Group Policy Editor.
Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System. In the System folder is an item called Turn off Autoplay. Double-click this to open it. Set the option to Enabled and select All drives from the drop-down.
posted by le morte de bea arthur at 1:54 PM on October 18, 2008

...but of course that's not on the USB side. Still, it's the closest to an answer there is.
posted by le morte de bea arthur at 1:55 PM on October 18, 2008

Best answer: Can you create a blank autorun.inf? Or if it ignores that, make an autorun.inf that points to a non-existent file or exe?
posted by Boobus Tuber at 2:00 PM on October 18, 2008

Response by poster: Boobus Tuber, that's the angle I'd like to take. Do you know if this would work? I'll start testing it out.
posted by SAC at 2:04 PM on October 18, 2008

Response by poster: Boobus Tuber, that'll work. It doesn't disable autorun, but it gets around the issue.

If I create a blank autorun.inf file, Windows seems to look through the drive to decide which options to offer. When I create an autorun.inf with:


(where Blank.txt doesn't exist) the prompt offers only to "Open folder to view files". I will have to test this out on more computers and specifically the conference room computer, but this should help me avoid the accidental opening of random pictures.

posted by SAC at 2:29 PM on October 18, 2008

>The guy running the meeting just clicked OK or something to get rid of it, and one of the pictures two or three folders deep came up.

What I do is keep a flash drive for work and another for personal. I almost never plug the personal one into work computers, especially ones plugged into projectors. That's really the only 100% solid solution avoiding personal items appearing on work computers.

The idea of letting my employers computer peek at my stuff is revolting. You should feel the same way. Not to mention "helpful" AV scanners thinking half my utilities are "hacktool."
posted by damn dirty ape at 2:35 PM on October 18, 2008 [1 favorite]

Once it is added to the computer, right click on the device in Windows Explorer and choose Properties. On the "Autoplay" tab there will be a choice for you to specify what to do when the device is added. One of those options is "Take no action".
posted by mmascolino at 2:35 PM on October 18, 2008

I can't find it at them moment, but I remember reading somewhere about changing a drive type bit on the actual drive, which makes Windows not do any autoplay business at all. Has anyone else heard of this?
posted by niles at 2:36 PM on October 18, 2008

Response by poster: damn dirty ape, I agree that the safest way would be to not mix the two. Having said that, I know that there's nothing on the drive that would get me in trouble or really embarrass me. This work-around seems like a simple enough of a solution for something that isn't a serious problem.

mmascolino, that would only then work for that one computer and I'd have to repeat it for every computer I connect it to. When I connect the thumbdrive to a computer, I assume I want to at least open the drive to get access to stuff on it. While I'd rather Windows not even ask, if it only offers is to open the drive, that works for me.
posted by SAC at 2:50 PM on October 18, 2008

Not a direct fix, but I keep my USB drive contents in a Steganos Safe. Inserting the drive causes the Safe software to run, which prompts you for a password before making the unencrypted data accessible as a separate drive.
posted by le morte de bea arthur at 4:13 PM on October 18, 2008

« Older SMS Alert Help   |   Recommend me some kiddie SF Newer »
This thread is closed to new comments.