Is my router (or Comcast) blocking i.dell.com?
October 7, 2008 10:29 AM   Subscribe

Something odd is happening on my internet connection at home. I have two machines both of which connect to the intenet via a Linksys Wireless-G Broadband Router (or Comcast variant on it) and a Comcast cable connection. Both of them do not display the Dell homepage properly. After viewing source I determined that they couldn’t find the supporting files at the subdomain i.dell.com (it’s possible other subdomains are missing as well, but that is the one causing the most dramatic effect). Viewing the site from another internet connection it appears fine. Is something up with the router, or with Comcast? Looking for steps to determine what is going on and (hopefully) rectify it.

Also, as a data point, I think I had something similar happen a while back where I couldn’t get to downloads from Windows Live Messenger from either machine, but could when not using that connection. That problem seemed to resolve itself somehow though.
posted by Artw to Computers & Internet (9 answers total) 1 user marked this as a favorite
 
I'd:

Reboot the cable modem. Usually you just unplug it from the wall for 10 seconds.

Reboot all network devices (routers, etc) and all the computers.

Try again. If it continues Id change the DNS settings on my clients to 4.2.2.2 (verizon) or OpenDNS (although I think thats a privacy risk).

If it continues then its not a DNS issue or an application issue. I would just call Comcast then.
posted by damn dirty ape at 11:00 AM on October 7, 2008


If it's a DNS-related error (which it most probably is), here's what you can do.

On your computers, open up command prompt and type "ipconfig /flushdns"

On your router, flush the DNS cache if there's an option. Otherwise, set them to opendns servers (208.67.222.222, 208.67.220.220)
posted by cyanide at 11:11 AM on October 7, 2008 [1 favorite]


Could be a DNS issue. What do you see if you open a command prompt and type "ping i.dell.com"?
posted by justkevin at 11:11 AM on October 7, 2008


@damn dirty ape:

Hopefully, this allays your privacy concerns (their official privacy policy is available, as well). I personally don't have any privacy concerns with them other than those that I would with any other ISP whose DNS I use. YMMV.

OpenDNS is wickedly fast. i recommend it highly.
posted by liquado at 11:38 AM on October 7, 2008


I know this is obvious but have you checked your hosts file, to see if idell.com is there? If you are running FF, do you have Adblock, which might block idell.com?
posted by TheRaven at 4:01 PM on October 7, 2008


justkevin - "Ping request could not find host i.dell.com. Please check the name and try again. "
TheRaven - No mention of dell in that dir.
posted by Artw at 8:08 PM on October 7, 2008


ipconfig /flushdns and unplugging the router both didn't work. IIRC its got a pinhole reset button, but I had trouble getting set up again after last doing that so I'm saving that one for a bit.
posted by Artw at 8:55 PM on October 7, 2008


I got access to the routers web configuration tool (turns out u and p were set to the defaults) and tried a DHCP renew - no effect. No sign of anything being blocked anywhere.

Still, knowing that makes me more confident reseting the thing.
posted by Artw at 9:16 PM on October 7, 2008


FWIW the images spontaneously started showing up again recently. Not sure what that was all about.
posted by Artw at 10:49 AM on November 19, 2008


« Older Floor me.   |   Help me build or buy the right system Newer »
This thread is closed to new comments.